Bug 80604 - [Qt] fast/css/resize-single-axis.html timeout
Summary: [Qt] fast/css/resize-single-axis.html timeout
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on: 80738
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-08 09:41 PST by Ádám Kallai
Modified: 2012-03-21 02:25 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ádám Kallai 2012-03-08 09:41:08 PST
Probable this revision (r110073) caused by the timeout.
Comment 1 Hironori Bono 2012-03-08 20:00:24 PST
Greetings,

Thanks for your bug report.
With regard to this issue, we have not been able to see a resizer at the bottom-right corner when we open this file. When I bisect our snapshots, this issue starts from Chromium snapshot r125525 (*1). Unfortunately, this Chromium issue still happens even when I locally roll out my r110073. (In my honest opinion, my r110073 changes the position of the resizer only of an RTL element, i.e. it should not affect LTR elements used in this file.)

(*1) http://commondatastorage.googleapis.com/chromium-browser-snapshots/Win/125525/chrome-win32.zip

To read our change log (*2), r110072 (*3) also changes RenderLayer and I would like to hear the thoughts of Julien.

(*2) http://commondatastorage.googleapis.com/chromium-browser-snapshots/Win/125525/changelog.xml
(*3) http://trac.webkit.org/changeset/110072

Regards,

Hironori Bono
Comment 2 Csaba Osztrogonác 2012-03-09 01:41:03 PST
It is skipped on Qt until proper fix - http://trac.webkit.org/changeset/110276/trunk/LayoutTests/platform/qt/Skipped
Comment 3 Julien Chaffraix 2012-03-09 09:35:42 PST
> With regard to this issue, we have not been able to see a resizer at the bottom-right corner when we open this file.

That is an (unintended) consequence of my change. The resizer is attached to the RenderLayer which we don't allocate as we have no layout overflow. The fix is to patch RenderBox::requiresLayerForOverflowClip to return true if style()->resize() != NONE.

Now that doesn't explain the timeout which is AFAICT unrelated.
Comment 4 Julien Chaffraix 2012-03-12 13:33:48 PDT
For the record, bug 80738 fixed the issue with the resizer not being present. As I don't know if the timeout is related to that, I haven't re-enabled the test on Qt.
Comment 5 Hironori Bono 2012-03-21 00:38:16 PDT
Greetings,

When I build Qt WebKit r111496 on my Ubuntu (11.04) PC and run this test on it, this test finishes without any errors or timeouts. Is it possible to re-enable this test and see it still fails?

Regards,

Hironori Bono
Comment 6 Csaba Osztrogonác 2012-03-21 02:25:17 PDT
It passes now, unskipped by http://trac.webkit.org/changeset/111514