Bug 80419 - for select element: 'required' attribute is not respected on Safari, Harmattan
Summary: for select element: 'required' attribute is not respected on Safari, Harmattan
Status: RESOLVED DUPLICATE of bug 28649
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other Other
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on: 50380
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-06 07:32 PST by Joel Parks
Modified: 2016-06-24 08:45 PDT (History)
6 users (show)

See Also:


Attachments
form with select element containing 'required' attribute for testing (1.38 KB, text/html)
2012-03-06 07:32 PST, Joel Parks
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joel Parks 2012-03-06 07:32:44 PST
Created attachment 130380 [details]
form with select element containing 'required' attribute for testing

Detected on Harmattan N9 and iPhone 4S and Safari 5.1.2 (7534.52.7) on Win7

STEPS LEADING TO PROBLEM AND OUTCOME: 
1. load attached file selectRequiredTesting.html
2. ensure that none of the options are marked in the select element
3. attempt to submit the form using the Submit button
4. ERROR: the form submission completes

EXPECTED OUTCOME:
The presence of the 'required' attribute on the select element in the
form should cause the browser to ensure that the 'value' of the select element
is defined before form submission.  Ideally it would abort the submit and
trigger an alert indicating the select element[s] with 'required' attribute set
and select 'value' undefined so that the user could correct the omission.

This feature is a lightweight method of enforcing user input rules and should
be supported as defined in the html5 specification:
http://dev.w3.org/html5/spec/Overview.html#attr-select-required
Comment 1 Joel Parks 2012-03-06 07:33:54 PST
works as expected on Chrome (and Firefox for that matter)
Comment 2 Alexey Proskuryakov 2014-09-08 23:29:17 PDT

*** This bug has been marked as a duplicate of bug 28649 ***