RESOLVED FIXED Bug 80255
Optimize for IPP in DirectConvolver::process()
https://bugs.webkit.org/show_bug.cgi?id=80255
Summary Optimize for IPP in DirectConvolver::process()
Xingnan Wang
Reported 2012-03-05 01:45:21 PST
reverb function in ipp library can be used.
Attachments
Patch (3.96 KB, patch)
2012-03-21 04:13 PDT, Xingnan Wang
no flags
Patch (4.33 KB, patch)
2012-03-21 20:18 PDT, Xingnan Wang
no flags
Xingnan Wang
Comment 1 2012-03-21 04:13:11 PDT
Xingnan Wang
Comment 2 2012-03-21 04:13:43 PDT
(In reply to comment #1) > Created an attachment (id=133008) [details] > Patch Uploaded the patch.
Xingnan Wang
Comment 3 2012-03-21 04:14:22 PDT
(In reply to comment #2) > (In reply to comment #1) > > Created an attachment (id=133008) [details] [details] > > Patch > > Uploaded the patch. Increase ~2X performance by conv() in IPP.
Chris Rogers
Comment 4 2012-03-21 10:53:39 PDT
Comment on attachment 133008 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=133008&action=review Xingnan, thanks for the patch. Have you run the convolution layout tests when WEBAUDIO_IPP is enabled? Also, please make sure to call m_overlayBuffer.zero() in the reset() method... > Source/WebCore/platform/audio/DirectConvolver.cpp:74 > + float* outputBuffer = m_inputBuffer.data(); It might make sense to rename this member variable more generally now: m_inputBuffer -> m_buffer since it's a bit confusing to see line 74
Xingnan Wang
Comment 5 2012-03-21 20:18:10 PDT
Xingnan Wang
Comment 6 2012-03-21 20:20:35 PDT
(In reply to comment #4) > (From update of attachment 133008 [details]) > View in context: https://bugs.webkit.org/attachment.cgi?id=133008&action=review > > Xingnan, thanks for the patch. Have you run the convolution layout tests when WEBAUDIO_IPP is enabled? Also, please make sure to call m_overlayBuffer.zero() in the reset() method... > All layout tests passed when WEBAUDIO_IPP is enabled, both Debug and Release build. > > Source/WebCore/platform/audio/DirectConvolver.cpp:74 > > + float* outputBuffer = m_inputBuffer.data(); > > It might make sense to rename this member variable more generally now: m_inputBuffer -> m_buffer > since it's a bit confusing to see line 74 Done.
Chris Rogers
Comment 7 2012-03-23 10:29:48 PDT
Comment on attachment 133177 [details] Patch Thanks!
WebKit Review Bot
Comment 8 2012-03-23 11:14:32 PDT
Comment on attachment 133177 [details] Patch Clearing flags on attachment: 133177 Committed r111880: <http://trac.webkit.org/changeset/111880>
WebKit Review Bot
Comment 9 2012-03-23 11:14:36 PDT
All reviewed patches have been landed. Closing bug.
Note You need to log in before you can comment on or make changes to this bug.