RESOLVED FIXED 80137
[EFL][DRT] Implements LayoutTestController's setPopupBlockingEnabled
https://bugs.webkit.org/show_bug.cgi?id=80137
Summary [EFL][DRT] Implements LayoutTestController's setPopupBlockingEnabled
Grzegorz Czajkowski
Reported 2012-03-02 02:54:04 PST
Adds implementation LayoutTestController's setPopupBlockingEnabled. I am working on this, patch will be uploaded.
Attachments
proposed patch (5.98 KB, patch)
2012-03-06 00:33 PST, Grzegorz Czajkowski
no flags
Grzegorz Czajkowski
Comment 1 2012-03-06 00:33:19 PST
Created attachment 130314 [details] proposed patch This patch: - implements LayoutTestController's setPopupBlockingEnabled, - enables tests connected with setPopupBlockingEnabled - deletes idler which called by scheduleAsynchronousClickCallback (EventSender.cpp), sendClick should be called only once to pass popup-blocking-click-in-iframe.html
Raphael Kubo da Costa (:rakuco)
Comment 2 2012-03-06 04:57:41 PST
Comment on attachment 130314 [details] proposed patch Looks fine.
Gyuyoung Kim
Comment 3 2012-03-06 05:55:35 PST
Comment on attachment 130314 [details] proposed patch Looks good too.
Eric Seidel (no email)
Comment 4 2012-03-06 23:36:59 PST
Comment on attachment 130314 [details] proposed patch View in context: https://bugs.webkit.org/attachment.cgi?id=130314&action=review LGTM. > Tools/DumpRenderTree/efl/LayoutTestControllerEfl.cpp:439 > +void LayoutTestController::setPopupBlockingEnabled(bool flag) Woudl be better to use a nicer name. Like enablePopupBlocking.
Grzegorz Czajkowski
Comment 5 2012-03-06 23:53:44 PST
(In reply to comment #4) > (From update of attachment 130314 [details]) > View in context: https://bugs.webkit.org/attachment.cgi?id=130314&action=review > > LGTM. > > > Tools/DumpRenderTree/efl/LayoutTestControllerEfl.cpp:439 > > +void LayoutTestController::setPopupBlockingEnabled(bool flag) > > Woudl be better to use a nicer name. Like enablePopupBlocking. Yes, but this implements a common interface for all WebKit ports (Tools/DumpRenderTree/LayoutTestController.h) We can change it while general refactoring of DRT in my opinion :)
WebKit Review Bot
Comment 6 2012-03-06 23:54:51 PST
Comment on attachment 130314 [details] proposed patch Clearing flags on attachment: 130314 Committed r110028: <http://trac.webkit.org/changeset/110028>
WebKit Review Bot
Comment 7 2012-03-06 23:54:55 PST
All reviewed patches have been landed. Closing bug.
Note You need to log in before you can comment on or make changes to this bug.