Bug 80118 - Changing <col> width should update table-layout:fixed <table>
Summary: Changing <col> width should update table-layout:fixed <table>
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tables (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-02 00:05 PST by Joseph Pecoraro
Modified: 2012-03-17 13:17 PDT (History)
3 users (show)

See Also:


Attachments
[REDUCTION] Test Case (1014 bytes, text/html)
2012-03-02 00:05 PST, Joseph Pecoraro
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph Pecoraro 2012-03-02 00:05:07 PST
Created attachment 129830 [details]
[REDUCTION] Test Case

See the simple test case. Clicking a button changes the column width
on a table-layout:fixed <table> but it doesn't update. I don't can't seem
to force it to update with JavaScript either.

• Opening the Web Inspector causes the content to update.=
• Works in Firefox.
Comment 1 Joseph Pecoraro 2012-03-02 00:05:23 PST
Seems similar to bug 15111:
<http://webkit.org/b/15111> Cell width can't be changed when the table is using table-layout:fixed and first row is using colspan.
Comment 2 Benjamin Poulain 2012-03-02 00:08:17 PST
Hey Julien, what is up? :)
Comment 3 Julien Chaffraix 2012-03-17 09:14:00 PDT
This seems to be working on ToT. Joseph, maybe you hit a temporary regression? (I don't recall any specific table regression though)
Comment 4 Joseph Pecoraro 2012-03-17 13:17:00 PDT
Yep, test case look like its working now! (r110761 nightly). Thanks =)