Bug 80035 - [Qt] Crash when opening a particular page at spiegel.de
Summary: [Qt] Crash when opening a particular page at spiegel.de
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other Linux
: P2 Major
Assignee: Nobody
URL: http://einestages.spiegel.de/static/t...
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-01 10:07 PST by Andreas
Modified: 2012-05-10 16:01 PDT (History)
3 users (show)

See Also:


Attachments
Backtrace (18.84 KB, text/plain)
2012-03-03 15:03 PST, Johannes Obermayr
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas 2012-03-01 10:07:23 PST
Got a reproducable crash when loading the page
http://einestages.spiegel.de/static/topicalbumbackground/24426/die_mark_die_nie_in_umlauf_kam.html
with no previous browsing activity.
My browser (supposedly due to webkit) crashes before the page is loaded completely. The problem could be flash related but I am using the current flashplugin beta for linux.
Browser is konqueror/rekonq on kubuntu 11.10 kde 4.8 backport.
Bug is confirmed by rekonq mailing list
https://bugs.kde.org/show_bug.cgi?id=295154
Comment 1 Alexey Proskuryakov 2012-03-02 14:24:50 PST
Seems Qt specific, I cannot reproduce in Safari ToT.
Comment 2 Johannes Obermayr 2012-03-03 15:03:23 PST
Created attachment 130009 [details]
Backtrace
Comment 3 Alexey Proskuryakov 2012-03-03 20:19:15 PST
What WebKit revision are you at? There we some crashes in RenderBlock::createLineBoxes fixed recently.
Comment 4 Johannes Obermayr 2012-03-04 04:10:24 PST
https://build.opensuse.org/package/files?package=libQtWebKit4&project=KDE%3AQt

Maybe you can make Dirk Müller to update the 5 months old thing on openSUSE ...
Comment 5 Andreas 2012-03-05 05:10:58 PST
Do not know the webkit revision but my ubuntu packages are
libkdewebkit5 4:4.8.0-0ubuntu1~oneric1~ppa1
etc.
Comment 6 Andreas 2012-03-12 12:43:11 PDT
Still present with recent kde 4.8.1 ubuntu backport. Do not know how to find the webkit version.
Comment 7 Andrea Diamantini 2012-05-10 15:56:43 PDT
I cannot reproduce this on my unofficial port. Let's say I cannot reproduce it on webkit master.
Comment 8 Andreas 2012-05-10 16:01:51 PDT
I still observe this bug in newest ubuntu packages. But this is a bug in the packaging. It seems to be fixed in the repository.