Bug 80015 - Make the tiling code slightly smarter
Summary: Make the tiling code slightly smarter
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Qt (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Kenneth Rohde Christiansen
Depends on:
Reported: 2012-03-01 01:29 PST by Kenneth Rohde Christiansen
Modified: 2012-03-01 01:54 PST (History)
1 user (show)

See Also:

Patch (9.57 KB, patch)
2012-03-01 01:53 PST, Kenneth Rohde Christiansen
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kenneth Rohde Christiansen 2012-03-01 01:29:15 PST
Avoid doing the same tranformations all over in each call to tileRectForCoordinate.

Do not resize tiles and then drop them because they are not out of the keep rect; instead drop before resizing.

Rename dropTilesOutsideRect to setKeepRect as it now stored the keep rect. This is used to avoid unneeded iteration of all tiles for invalidates outside the keep rect.
Comment 1 Kenneth Rohde Christiansen 2012-03-01 01:53:00 PST
Created attachment 129666 [details]
Comment 2 Kenneth Rohde Christiansen 2012-03-01 01:54:45 PST
Landed in 109327.