Bug 79783 - [Qt] Buildfix after moving WTF out of JavaScriptCore
: [Qt] Buildfix after moving WTF out of JavaScriptCore
Status: RESOLVED DUPLICATE of bug 81844
: WebKit
Tools / Tests
: 528+ (Nightly build)
: Unspecified Unspecified
: P2 Normal
Assigned To:
:
: Qt, QtTriaged
:
: 75673
  Show dependency treegraph
 
Reported: 2012-02-28 06:55 PST by
Modified: 2012-03-22 15:29 PST (History)


Attachments
proposed fix (6.82 KB, patch)
2012-02-28 07:18 PST, Csaba Osztrogonác
vestbo: review+
ossy: commit‑queue-
Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2012-02-28 06:55:40 PST
Patch is coming soon.
------- Comment #1 From 2012-02-28 07:18:40 PST -------
Created an attachment (id=129244) [details]
proposed fix

It should be landed after WTF moved out.
------- Comment #2 From 2012-02-28 07:22:49 PST -------
(From update of attachment 129244 [details])
View in context: https://bugs.webkit.org/attachment.cgi?id=129244&action=review

> Tools/DumpRenderTree/qt/DumpRenderTree.pro:22
> +    $${ROOT_WEBKIT_DIR}/Source/JavaScriptCore \
> +    $${ROOT_WEBKIT_DIR}/Source/JavaScriptCore/runtime

It is needed to make DRT build, because
- Tools/DumpRenderTree/config.h includes <runtime/JSExportMacros.h>
- Source/WTF/config.h includes "JSExportMacros.h"

I know it isn't the nicest fix, but it works. :)
------- Comment #3 From 2012-02-28 07:24:44 PST -------
(From update of attachment 129244 [details])
Attachment 129244 [details] did not pass qt-ews (qt):
Output: http://queues.webkit.org/results/11650160
------- Comment #4 From 2012-02-28 07:25:46 PST -------
(In reply to comment #3)
> (From update of attachment 129244 [details] [details])
> Attachment 129244 [details] [details] did not pass qt-ews (qt):
> Output: http://queues.webkit.org/results/11650160

Of course it doesn't build now, but it will after moving out WTF. ;)
------- Comment #5 From 2012-02-28 07:35:10 PST -------
(From update of attachment 129244 [details])
View in context: https://bugs.webkit.org/attachment.cgi?id=129244&action=review

r=me, but try the WEBKIT trick first

>> Tools/DumpRenderTree/qt/DumpRenderTree.pro:22
>> +    $${ROOT_WEBKIT_DIR}/Source/JavaScriptCore/runtime
> 
> It is needed to make DRT build, because
> - Tools/DumpRenderTree/config.h includes <runtime/JSExportMacros.h>
> - Source/WTF/config.h includes "JSExportMacros.h"
> 
> I know it isn't the nicest fix, but it works. :)

You should be able to replace this with modifying WEBKIT above:

WEBKIT += wtf javascriptcore webcore
------- Comment #6 From 2012-02-28 07:43:23 PST -------
(In reply to comment #5)
> You should be able to replace this with modifying WEBKIT above:
> 
> WEBKIT += wtf javascriptcore webcore

We have javascriptcore.prf, qt_webkit.prf, webcore.prf, webkit2.prf and
wtf.prf named files now. I think we should change them later, separately
from this bug if we really want to do it.
------- Comment #7 From 2012-02-28 07:58:01 PST -------
(In reply to comment #6)
> (In reply to comment #5)
> > You should be able to replace this with modifying WEBKIT above:
> > 
> > WEBKIT += wtf javascriptcore webcore
> 
> We have javascriptcore.prf, qt_webkit.prf, webcore.prf, webkit2.prf and
> wtf.prf named files now. I think we should change them later, separately
> from this bug if we really want to do it.

What do you mean?
------- Comment #8 From 2012-02-28 08:03:30 PST -------
(In reply to comment #7)
> (In reply to comment #6)
> > (In reply to comment #5)
> > > You should be able to replace this with modifying WEBKIT above:
> > > 
> > > WEBKIT += wtf javascriptcore webcore
> > 
> > We have javascriptcore.prf, qt_webkit.prf, webcore.prf, webkit2.prf and
> > wtf.prf named files now. I think we should change them later, separately
> > from this bug if we really want to do it.
> 
> What do you mean?

I meant that prf's has lowercase only names now.

If we change wtf to WTF, we should change javascriptcore 
to JavaScriptCore and webcore to WebCore, ...
------- Comment #9 From 2012-02-28 08:43:47 PST -------
(In reply to comment #8)
> (In reply to comment #7)
> > (In reply to comment #6)
> > > (In reply to comment #5)
> > > > You should be able to replace this with modifying WEBKIT above:
> > > > 
> > > > WEBKIT += wtf javascriptcore webcore
> > > 
> > > We have javascriptcore.prf, qt_webkit.prf, webcore.prf, webkit2.prf and
> > > wtf.prf named files now. I think we should change them later, separately
> > > from this bug if we really want to do it.
> > 
> > What do you mean?
> 
> I meant that prf's has lowercase only names now.
> 
> If we change wtf to WTF, we should change javascriptcore 
> to JavaScriptCore and webcore to WebCore, ...

Um, the WEBKIT variable has all lowercase values, there's no inconsistency, and no reason to make 'wtf' be 'WTF'. It's consistent with the QT variable, which also lists the qt modules you depend on, all lowercase.

What I was suggesting was the proper fix for the includepath-problem. If you disagree about the casing of the values of the WEBKIT variable that's no reason to not use the mechanism to solve the issue of the includepaths?
------- Comment #10 From 2012-02-28 09:11:51 PST -------
Sorry, I absolutely misinterpreted you.

You suggested using "WEBKIT += wtf javascriptcore webcore"
instead of adding more includepaths to DRT.pro. I got it now. :)

I can check it tomorrow, but not today.
------- Comment #11 From 2012-03-22 15:29:38 PST -------
It was merged to https://bugs.webkit.org/show_bug.cgi?id=81844

*** This bug has been marked as a duplicate of bug 81844 ***