Bug 7976 - Change the way RenderStyles are created to avoid floating objects
Summary: Change the way RenderStyles are created to avoid floating objects
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P4 Normal
Assignee: Eric Seidel (no email)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-25 02:49 PST by Eric Seidel (no email)
Modified: 2009-01-02 00:06 PST (History)
1 user (show)

See Also:


Attachments
Make RenderStyle objects no longer float (14.51 KB, patch)
2006-03-25 02:50 PST, Eric Seidel (no email)
mjs: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2006-03-25 02:49:28 PST
This patch makes RenderStyles no longer float (with a ref count of 0) during the initial style resolve.
Comment 1 Eric Seidel (no email) 2006-03-25 02:50:16 PST
Created attachment 7292 [details]
Make RenderStyle objects no longer float
Comment 2 Alexey Proskuryakov 2009-01-02 00:06:06 PST
*** Bug 9278 has been marked as a duplicate of this bug. ***