Bug 79723 - [chromium] Rename LayerChromium::name to debugName to be more consistent with other debug properties, make threadsafe
Summary: [chromium] Rename LayerChromium::name to debugName to be more consistent with...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: James Robinson
URL:
Keywords:
Depends on:
Blocks: 67499 79428
  Show dependency treegraph
 
Reported: 2012-02-27 17:31 PST by James Robinson
Modified: 2012-03-01 16:48 PST (History)
5 users (show)

See Also:


Attachments
Patch (10.50 KB, patch)
2012-02-27 17:32 PST, James Robinson
enne: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description James Robinson 2012-02-27 17:31:51 PST
[chromium] Rename LayerChromium::name to debugName to be more consistent with other debug properties, make threadsafe
Comment 1 James Robinson 2012-02-27 17:32:20 PST
Created attachment 129147 [details]
Patch
Comment 2 Adrienne Walker 2012-03-01 10:03:41 PST
Comment on attachment 129147 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=129147&action=review

Yay, thread safety.

> Source/WebKit/chromium/tests/LayerChromiumTest.cpp:-492
> -    EXECUTE_AND_VERIFY_SET_NEEDS_COMMIT_BEHAVIOR(0, testLayer->setName("Test Layer"));

nit: Can you move this line to the section that makes sure it does call needsCommit rather than just removing it?
Comment 3 James Robinson 2012-03-01 16:48:09 PST
Committed r109466: <http://trac.webkit.org/changeset/109466>
Comment 4 James Robinson 2012-03-01 16:48:58 PST
(In reply to comment #2)
> (From update of attachment 129147 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=129147&action=review
> 
> Yay, thread safety.
> 
> > Source/WebKit/chromium/tests/LayerChromiumTest.cpp:-492
> > -    EXECUTE_AND_VERIFY_SET_NEEDS_COMMIT_BEHAVIOR(0, testLayer->setName("Test Layer"));
> 
> nit: Can you move this line to the section that makes sure it does call needsCommit rather than just removing it?

Done!