ContextDestructionObserver should live in its own file
Created attachment 128943 [details]
Comment on attachment 128943 [details]
This can just be a ContextObserver or ScriptContextObserver considering that we're going to rename FrameDestructionObserver to FrameObserver.
ap seemed somewhat negative on renaming FrameDestructionObserver, so I'm inclined to keep this name.
Committed r108954: <http://trac.webkit.org/changeset/108954>