Bug 79328 - [Qt] Build fix. macro "QSKIP" takes 1 arguments on Qt5, but takes 2 on Qt4.
Summary: [Qt] Build fix. macro "QSKIP" takes 1 arguments on Qt5, but takes 2 on Qt4.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Qt (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Holger Freyther
URL:
Keywords:
: 79323 (view as bug list)
Depends on: 79402
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-22 22:04 PST by Dongseong Hwang
Modified: 2012-02-24 06:36 PST (History)
10 users (show)

See Also:


Attachments
patch (7.21 KB, patch)
2012-02-22 22:06 PST, Dongseong Hwang
no flags Details | Formatted Diff | Diff
Patch (9.39 KB, patch)
2012-02-23 11:18 PST, Holger Freyther
no flags Details | Formatted Diff | Diff
Patch (9.40 KB, patch)
2012-02-23 11:22 PST, Holger Freyther
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dongseong Hwang 2012-02-22 22:04:39 PST
Build fix. macro "QSKIP" takes 1 arguments on Qt5, but takes 2 on Qt4.

This patch causes to be able to build WebKit2 on Qt5.
Comment 1 Dongseong Hwang 2012-02-22 22:06:05 PST
Created attachment 128392 [details]
patch
Comment 2 Simon Hausmann 2012-02-23 00:59:13 PST
Comment on attachment 128392 [details]
patch

This isn't pretty, but oh well :)
Comment 3 WebKit Review Bot 2012-02-23 02:14:48 PST
Comment on attachment 128392 [details]
patch

Rejecting attachment 128392 [details] from commit-queue.

Failed to run "['/mnt/git/webkit-commit-queue/Tools/Scripts/webkit-patch', '--status-host=queues.webkit.org', '-..." exit_code: 2

Last 500 characters of output:
webkit.org/repository/webkit': could not connect to server (http://svn.webkit.org) at /usr/lib/git-core/git-svn line 2295

Died at Tools/Scripts/update-webkit line 164.

Failed to run "['Tools/Scripts/update-webkit', '--chromium', '--force-update']" exit_code: 9
Updating OpenSource
RA layer request failed: OPTIONS of 'http://svn.webkit.org/repository/webkit': could not connect to server (http://svn.webkit.org) at /usr/lib/git-core/git-svn line 2295

Died at Tools/Scripts/update-webkit line 164.

Full output: http://queues.webkit.org/results/11610177
Comment 4 Holger Freyther 2012-02-23 09:08:48 PST
*** Bug 79323 has been marked as a duplicate of this bug. ***
Comment 5 Holger Freyther 2012-02-23 09:09:36 PST
(In reply to comment #2)
> (From update of attachment 128392 [details])
> This isn't pretty, but oh well :)

we have utils.h already and can have W_QSKIP.. anyway.. too late now.
Comment 6 Simon Hausmann 2012-02-23 10:34:32 PST
(In reply to comment #5)
> (In reply to comment #2)
> > (From update of attachment 128392 [details] [details])
> > This isn't pretty, but oh well :)
> 
> we have utils.h already and can have W_QSKIP.. anyway.. too late now.

Good idea :) and not too late, since the bot couldn't apply it.
Comment 7 Holger Freyther 2012-02-23 11:18:38 PST
Created attachment 128510 [details]
Patch
Comment 8 Holger Freyther 2012-02-23 11:22:34 PST
Created attachment 128512 [details]
Patch
Comment 9 Csaba Osztrogonác 2012-02-23 12:24:26 PST
Comment on attachment 128512 [details]
Patch

r=me. Just a quick question: Won't it break the build with previous version of Qt5?
If yes, then I'll land it with updating Qt5 on the bots tomorrow morning.
Comment 10 Holger Freyther 2012-02-23 12:26:18 PST
Yeah, you are right. I wish Qt would have a date/week stamp we could use...
Comment 11 Csaba Osztrogonác 2012-02-23 12:32:59 PST
(In reply to comment #10)
> Yeah, you are right. I wish Qt would have a date/week stamp we could use...

Webkit trunk is always buildable with weekly pinned Qt5 hash which you can find here: https://github.com/ossy-szeged/qt5-tools

- build-qt5-env - It contains an incremental revision number and the weekly Qt5 hash
- build-qt5.sh - I use this script to update Qt5 on the bots.

Additionally I always send a mail to webkit-qt mailing list after weekly update on all friday. (Sometimes it is postponed because of some regressions.) And you can find which WK revision use which Qt5 hash here: http://build.webkit.sed.hu/buildslaves/szeged-linux-22

PS. Thanks for the fix, I'll land it manually tomorrow morning.
Comment 12 WebKit Commit Bot 2012-02-24 01:53:46 PST
Attachment 128512 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebKit/qt/ChangeLog', u'Source/WebK..." exit_code: 1
Source/WebKit/qt/tests/benchmarks/loading/tst_loading.cpp:28:  Alphabetical sorting problem.  [build/include_order] [4]
Source/WebKit/qt/tests/benchmarks/painting/tst_painting.cpp:29:  Alphabetical sorting problem.  [build/include_order] [4]
Total errors found: 2 in 8 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 13 Csaba Osztrogonác 2012-02-24 06:36:14 PST
Comment on attachment 128512 [details]
Patch

Clearing flags on attachment: 128512

Committed r108786: <http://trac.webkit.org/changeset/108786>
Comment 14 Csaba Osztrogonác 2012-02-24 06:36:22 PST
All reviewed patches have been landed.  Closing bug.