Bug 7920 - gmail steals tab focus and window focus about once every 60 seconds
: gmail steals tab focus and window focus about once every 60 seconds
Status: RESOLVED DUPLICATE of bug 7747
Product: WebKit
Classification: Unclassified
Component: WebKit Website
: 420+
: Macintosh Mac OS X 10.4
: P2 Major
Assigned To: Nobody
Depends on:
  Show dependency treegraph
Reported: 2006-03-22 15:48 PST by Jim
Modified: 2006-03-22 16:09 PST (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Jim 2006-03-22 15:48:20 PST
i'm just testing out the latest nightly build, and i noticed that gmail reloads info from the server about once every minute now, and every time it does it, it steals tab focus in the window, and also bring that specific window infront of all other safari windows and makes it active. while writing this it's stole focus about 6 times (bit more than once a minute), and each time i've ended typing a few characters in gmail :P

it basically leaves safari as the most annoying browser in history to use if you normally leave your gmail inbox (or any other part of gmail) open in a tab for easy access during regular use.

there is a simular bug reported already, but its for any version of safari, but its only when you manually click on an email (or sent mail, contacts, etc.) and then change tab, it'll steal back tab focus when its done loading. it wont steal window focus. http://bugzilla.opendarwin.org/show_bug.cgi?id=3779
Comment 1 mitz@webkit.org 2006-03-22 16:03:17 PST
This is actually a duplicate of bug 7747, which was fixed in r13436, so the fix should be in the r13442 (or any later) nightly.

*** This bug has been marked as a duplicate of 7747 ***
Comment 2 Jim 2006-03-22 16:09:15 PST
ah, i searched for open bugs... since i had just used nightshift (due to lazyness) to download the latest nightly build, and i was having the issue... i'll try tomorrow or the day after to get the nightly build again...