Bug 79155 - [chromium] Wire up shouldUpdateScrollPositionOnMainThread and nonFastScrollableRegion to compositor
Summary: [chromium] Wire up shouldUpdateScrollPositionOnMainThread and nonFastScrollab...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: James Robinson
URL:
Keywords:
: 71385 74196 (view as bug list)
Depends on: 79133
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-21 15:33 PST by James Robinson
Modified: 2012-07-27 02:29 PDT (History)
10 users (show)

See Also:


Attachments
Patch (15.21 KB, patch)
2012-02-21 15:36 PST, James Robinson
no flags Details | Formatted Diff | Diff
rebase (15.21 KB, patch)
2012-02-21 17:16 PST, James Robinson
no flags Details | Formatted Diff | Diff
map points from viewport to content space before hit testing (17.66 KB, patch)
2012-02-21 18:29 PST, James Robinson
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description James Robinson 2012-02-21 15:33:26 PST
[chromium] Wire up shouldUpdateScrollPositionOnMainThread and nonFastScrollableRegion to compositor
Comment 1 James Robinson 2012-02-21 15:36:17 PST
Created attachment 128060 [details]
Patch
Comment 2 James Robinson 2012-02-21 17:16:08 PST
Created attachment 128090 [details]
rebase
Comment 3 James Robinson 2012-02-21 18:29:14 PST
Created attachment 128101 [details]
map points from viewport to content space before hit testing
Comment 4 James Robinson 2012-02-21 20:46:53 PST
*** Bug 74196 has been marked as a duplicate of this bug. ***
Comment 5 Adam Barth 2012-02-23 23:12:08 PST
Comment on attachment 128101 [details]
map points from viewport to content space before hit testing

Looks pretty straightforward.  Let me know if you'd rather have someone who's an expert on the compositor reviewing these patches.
Comment 6 James Robinson 2012-02-26 17:04:38 PST
Comment on attachment 128101 [details]
map points from viewport to content space before hit testing

Clearing flags on attachment: 128101

Committed r108937: <http://trac.webkit.org/changeset/108937>
Comment 7 James Robinson 2012-02-26 17:04:42 PST
All reviewed patches have been landed.  Closing bug.
Comment 8 Sami Kyöstilä 2012-07-27 02:29:43 PDT
*** Bug 71385 has been marked as a duplicate of this bug. ***