Bug 78373 - REGRESSION: Perf-o-matic adds duplicated test results
Summary: REGRESSION: Perf-o-matic adds duplicated test results
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Website (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Ryosuke Niwa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-10 12:46 PST by Ryosuke Niwa
Modified: 2012-02-12 21:45 PST (History)
2 users (show)

See Also:


Attachments
Fixes the bug (5.08 KB, patch)
2012-02-10 12:54 PST, Ryosuke Niwa
no flags Details | Formatted Diff | Diff
Added the code to merge existing duplicates (10.26 KB, patch)
2012-02-10 15:04 PST, Ryosuke Niwa
no flags Details | Formatted Diff | Diff
Patch (5.50 KB, patch)
2012-02-12 21:13 PST, Ryosuke Niwa
morrita: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryosuke Niwa 2012-02-10 12:46:19 PST
After r107386, perf-o-matic adds test results via task queue. However, this results in duplicated test results because Build object is no longer acting as the gate keeper.
Comment 1 Ryosuke Niwa 2012-02-10 12:54:59 PST
Created attachment 126563 [details]
Fixes the bug
Comment 2 Ryosuke Niwa 2012-02-10 15:04:20 PST
Created attachment 126590 [details]
Added the code to merge existing duplicates
Comment 3 Ryosuke Niwa 2012-02-12 21:13:36 PST
Created attachment 126710 [details]
Patch
Comment 4 Ryosuke Niwa 2012-02-12 21:45:13 PST
Committed r107531: <http://trac.webkit.org/changeset/107531>