The current class names defined in ContentInclusionSelector are not intuitive.
It would be nice that we have more intuitive names which use the terms defined in the spec.
How about this?
ContentInclusionSelector -> HostChildNodesSelector
ShadowInclusionSet -> HostChildNodesSelectionSet
ShadowInclusionList -> HostChildNodesSelectionList
ShadowInclusion -> HostChildNodesSelection
If there is no objection, let me rename.
"Nodes" looks redundant, especially inside a noun? I guess it's ok to rename it HTMLContent something, considering it's for <content>. and they are under html/shadow.
Let me rename as follows:
ContentInclusionSelector -> HTMLContentSelector
ShadowInclusionSet -> HTMLContentSelectionSet
ShadowInclusionList -> HTMLContentSelectionList
ShadowInclusion -> HTMLContentSelection
I also rename member functions and variables to match the names.
(In reply to comment #2)
> "Nodes" looks redundant, especially inside a noun? I guess it's ok to rename it HTMLContent something, considering it's for <content>. and they are under html/shadow.
Created attachment 126488 [details]
Created attachment 126493 [details]
Most renaming is done. The patch is reedy for review.
Follow-up patch will do remaining renaming, such as renaming window.Internals binding.
Morrita-san, could you take a look?
Comment on attachment 126493 [details]
Clearing flags on attachment: 126493
Committed r107558: <http://trac.webkit.org/changeset/107558>
All reviewed patches have been landed. Closing bug.