Bug 78317 - Followup to: doesn't open most webarchive files.
Summary: Followup to: doesn't open most webarchive files.
Status: RESOLVED DUPLICATE of bug 78143
Alias: None
Product: WebKit
Classification: Unclassified
Component: UI Events (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.7
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-09 19:24 PST by clear111
Modified: 2012-02-09 22:21 PST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description clear111 2012-02-09 19:24:24 PST
The files are from an internet dating site, and are very personal, so unfortunately I cannot share them.
I don’t remember if I mentioned that they were from 2009. Perhaps something changed after that time, in the webarchive files are written or read. I also don’t remember if I mentioned that the regular Safari opens them without a problem. Is there a difference in the way a webarchive file is read and interpreted, between the regular Safari and WebKit?

Wait a minute! I think that I’ve figured it out!

The files that WebKit couldn’t open all begin with a date and time containing slashes! Sometimes the OS tolerates slashes in a file name, and sometimes it doesn’t. I don’t know why that is, but a friend with a new MacBook Air had file names with slashes, and the OS opened some of them but not others! The app was Pages.

Here are three file names that WebKit couldn’t open: 
03/24/2009 11-15 AM.webarchive
04/10/2009.webarchive
04/10/2009-1.webarchive

The file name that it could open is: xxxxxxxxxxX0X0 profile.webarchive
The lower case x-es represent lower case letters in the file name, the upper case X-es represent upper case letters in the file name, and the 0-s represent numbers in the file name.

You could try changing the name of a webarchive file that you have to 03/24/2009 11-15 AM.webarchive and see what happens when you try to open it.

BTW, I’m using an iMac with Mac OS 10.7.3.

Sincerely,
clear111


On Feb 9, 2012, at 1:48 PM, bugzilla-daemon@webkit.org wrote:

https://bugs.webkit.org/show_bug.cgi?id=78143


Alexey Proskuryakov <ap@webkit.org> changed:

         What    |Removed                     |Added
----------------------------------------------------------------------------
          Summary|doesn't open most           |REGRESSION (5.1.3 - ToT):
                 |webarchive files            |doesn't open most
                 |                            |webarchive files
         Priority|P2                          |P1
               CC|                            |ap@webkit.org




--- Comment #1 from Alexey Proskuryakov <ap@webkit.org>  2012-02-09 10:48:52 PST ---
Could you please attach the affected files? 

This sounds like a bad problem, but there is not much we can do to fix it if there is no way to reproduce.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You reported the bug.
Comment 1 Alexey Proskuryakov 2012-02-09 22:21:43 PST

*** This bug has been marked as a duplicate of bug 78143 ***