Bug 78246 - [chromium] Let WebKit::initialize call InitWebCoreSystemInterface on mac.
Summary: [chromium] Let WebKit::initialize call InitWebCoreSystemInterface on mac.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nico Weber
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-09 09:52 PST by Nico Weber
Modified: 2012-02-13 15:11 PST (History)
5 users (show)

See Also:


Attachments
Patch (2.02 KB, patch)
2012-02-09 09:55 PST, Nico Weber
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nico Weber 2012-02-09 09:52:18 PST
[chromium] Let WebKit::initialize call InitWebCoreSystemInterface on mac.
Comment 1 Nico Weber 2012-02-09 09:55:06 PST
Created attachment 126319 [details]
Patch
Comment 2 Tony Chang 2012-02-09 09:59:33 PST
Seems fine to me, but let's let fishd take a look.
Comment 3 Avi Drissman 2012-02-09 09:59:50 PST
LGTM
Comment 4 Darin Fisher (:fishd, Google) 2012-02-13 13:27:50 PST
Comment on attachment 126319 [details]
Patch

You shouldn't need to worry about WebKit::initialize() being called more than once per process.
Comment 5 WebKit Review Bot 2012-02-13 15:10:54 PST
Comment on attachment 126319 [details]
Patch

Clearing flags on attachment: 126319

Committed r107618: <http://trac.webkit.org/changeset/107618>
Comment 6 WebKit Review Bot 2012-02-13 15:11:00 PST
All reviewed patches have been landed.  Closing bug.