Bug 7824 - Push parts of form submission code down into Frame.cpp
Summary: Push parts of form submission code down into Frame.cpp
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: 420+
Hardware: Mac OS X 10.4
: P4 Normal
Assignee: Eric Seidel (no email)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-17 01:44 PST by Eric Seidel (no email)
Modified: 2006-03-19 23:36 PST (History)
0 users

See Also:


Attachments
push parts of MacFrame into Frame, GraphicsContextMac into GraphicsContext (70.32 KB, patch)
2006-03-18 00:53 PST, Eric Seidel (no email)
darin: review+
Details | Formatted Diff | Diff
Same patch, updated after rename changes. (62.06 KB, patch)
2006-03-19 21:08 PST, Eric Seidel (no email)
no flags Details | Formatted Diff | Diff
Better patch, with darin's suggested changes. (67.10 KB, patch)
2006-03-19 21:23 PST, Eric Seidel (no email)
no flags Details | Formatted Diff | Diff
Better patch, now also moving all Frame members to FramePrivate (70.69 KB, patch)
2006-03-19 21:35 PST, Eric Seidel (no email)
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2006-03-17 01:44:11 PST
Push parts of form submission code down into Frame.cpp

If this form submits, we'll know the patch works. :)
Comment 1 Eric Seidel (no email) 2006-03-18 00:53:47 PST
Created attachment 7145 [details]
push parts of MacFrame into Frame, GraphicsContextMac into GraphicsContext

4th attempt to post this patch.
Comment 2 Darin Adler 2006-03-18 04:32:17 PST
Comment on attachment 7145 [details]
push parts of MacFrame into Frame, GraphicsContextMac into GraphicsContext

I'd think you could just rename drawFloatImage to drawImage.

+    ~GraphicsContextPrivate();

Seems unnnecessary. The default destructor will do the job.

+    int width = ((s == BSTop || s == BSBottom) ? y2 - y1 : x2 - x1 );

Space before that last parenthesis looks strange to me. Maybe remove the outer parentheses altogether?

Adding these values directly to Frame rather than to FramePrivate seems like it might be moving in the wrong direction. Not sure. Are we planning to get rid of FramePrivate?

I think recordFormValue should take a PassRefPtr rather than a raw pointer.

Seems OK to land as-is. r=me
Comment 3 Eric Seidel (no email) 2006-03-19 21:08:09 PST
Created attachment 7181 [details]
Same patch, updated after rename changes.
Comment 4 Eric Seidel (no email) 2006-03-19 21:23:01 PST
Created attachment 7182 [details]
Better patch, with darin's suggested changes.
Comment 5 Eric Seidel (no email) 2006-03-19 21:35:38 PST
Created attachment 7183 [details]
Better patch, now also moving all Frame members to FramePrivate
Comment 6 Darin Adler 2006-03-19 21:37:27 PST
Comment on attachment 7183 [details]
Better patch, now also moving all Frame members to FramePrivate

r=me