WebKit Bugzilla
New
Browse
Log In
×
Sign in with GitHub
or
Remember my login
Create Account
·
Forgot Password
Forgotten password account recovery
RESOLVED FIXED
Bug 78224
Code generators should support multiple values for the [CallWith=] attribute
https://bugs.webkit.org/show_bug.cgi?id=78224
Summary
Code generators should support multiple values for the [CallWith=] attribute
Kentaro Hara
Reported
2012-02-09 05:13:08 PST
Currently we can specify only one value for one [CallWith=], like [CallWith=ScriptExecutionContext] or [CallWith=ScriptState]. To reduce redundant IDL attributes, we are planning to support multiple values for [CallWith=], like [CallWith=ScriptExecutionContext|ScriptArguments|CallStack]. In this bug, we make a change on code generators.
Attachments
Patch
(74.61 KB, patch)
2012-02-09 05:29 PST
,
Kentaro Hara
no flags
Details
Formatted Diff
Diff
rebased patch for commit
(74.25 KB, patch)
2012-02-09 17:08 PST
,
Kentaro Hara
no flags
Details
Formatted Diff
Diff
View All
Add attachment
proposed patch, testcase, etc.
Kentaro Hara
Comment 1
2012-02-09 05:29:30 PST
Created
attachment 126287
[details]
Patch
WebKit Review Bot
Comment 2
2012-02-09 05:30:41 PST
Attachment 126287
[details]
did not pass style-queue: Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCor..." exit_code: 1 Source/WebCore/bindings/scripts/test/GObject/WebKitDOMTestObj.cpp:326: Local variables should never be PassRefPtr (see
http://webkit.org/coding/RefPtr.html
). [readability/pass_ptr] [5] Source/WebCore/bindings/scripts/test/GObject/WebKitDOMTestObj.cpp:341: Local variables should never be PassRefPtr (see
http://webkit.org/coding/RefPtr.html
). [readability/pass_ptr] [5] Source/WebCore/bindings/scripts/test/GObject/WebKitDOMTestObj.cpp:1202: Local variables should never be PassRefPtr (see
http://webkit.org/coding/RefPtr.html
). [readability/pass_ptr] [5] Source/WebCore/bindings/scripts/test/GObject/WebKitDOMTestObj.cpp:1215: Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons. [readability/comparison_to_zero] [5] Source/WebCore/bindings/scripts/test/GObject/WebKitDOMTestObj.cpp:1229: Local variables should never be PassRefPtr (see
http://webkit.org/coding/RefPtr.html
). [readability/pass_ptr] [5] Source/WebCore/bindings/scripts/test/GObject/WebKitDOMTestObj.cpp:1246: Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons. [readability/comparison_to_zero] [5] Source/WebCore/bindings/scripts/test/GObject/WebKitDOMTestObj.cpp:1264: Local variables should never be PassRefPtr (see
http://webkit.org/coding/RefPtr.html
). [readability/pass_ptr] [5] Source/WebCore/bindings/scripts/test/GObject/WebKitDOMTestObj.cpp:1277: Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons. [readability/comparison_to_zero] [5] Total errors found: 8 in 14 files If any of these errors are false positives, please file a bug against check-webkit-style.
Adam Barth
Comment 3
2012-02-09 11:04:59 PST
Comment on
attachment 126287
[details]
Patch View in context:
https://bugs.webkit.org/attachment.cgi?id=126287&action=review
> Source/WebCore/bindings/scripts/CodeGenerator.pm:641 > +sub CallWithContains
This doesn't seem specific to CallWith. Should we give this a more general name like "ExtendedAttributeContains" or "AttributeContains"?
> Source/WebCore/bindings/scripts/CodeGeneratorV8.pm:1457 > sub GenerateCallWith
Should this function error out if there's something in the CallWith attribute that we don't understand?
Kentaro Hara
Comment 4
2012-02-09 17:08:54 PST
Created
attachment 126407
[details]
rebased patch for commit
Kentaro Hara
Comment 5
2012-02-09 17:10:52 PST
(In reply to
comment #3
)
> (From update of
attachment 126287
[details]
) > View in context:
https://bugs.webkit.org/attachment.cgi?id=126287&action=review
> > > Source/WebCore/bindings/scripts/CodeGenerator.pm:641 > > +sub CallWithContains > > This doesn't seem specific to CallWith. Should we give this a more general name like "ExtendedAttributeContains" or "AttributeContains"?
Makes sense. Renamed to "ExtendedAttributeContains".
> > Source/WebCore/bindings/scripts/CodeGeneratorV8.pm:1457 > > sub GenerateCallWith > > Should this function error out if there's something in the CallWith attribute that we don't understand?
For now I would like to skip it. I am planning to implement "IDL attribute checker" after cleaning up all IDLs, and include the CallWith values check there.
Kentaro Hara
Comment 6
2012-02-09 17:12:05 PST
Committed
r107314
: <
http://trac.webkit.org/changeset/107314
>
Kentaro Hara
Comment 7
2012-02-09 17:22:56 PST
Comment on
attachment 126287
[details]
Patch Landed manually to avoid style check errors in generated code.
Note
You need to
log in
before you can comment on or make changes to this bug.
Top of Page
Format For Printing
XML
Clone This Bug