Bug 7814 - Back button behaves incorrectly on Wikipedia "Random Article" link
: Back button behaves incorrectly on Wikipedia "Random Article" link
Status: RESOLVED DUPLICATE of bug 19422
Product: WebKit
Classification: Unclassified
Component: History
: 420+
: Macintosh Mac OS X 10.4
: P2 Normal
Assigned To: Nobody
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-16 19:44 PST by Devin Chalmers
Modified: 2009-10-20 07:20 PDT (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Devin Chalmers 2006-03-16 19:44:02 PST
When using Safari on the Wikipedia, clicking the "Random Article" link does not properly add pages to the history. Clicking several times on the link, and then clicking the "back" button, returns the browser to the page where the link was originally clicked.

Steps to reproduce:
1. Navigate to the Wikipedia English main page, http://en.wikipedia.org/
2. Click "Random Article" - note page title.
3. Click "Random Article" again
4. Click the Safari back button. Safari returns you to the Wikipedia main page, instead of the page found in step 2.
Comment 1 David Kilzer (:ddkilzer) 2006-05-28 06:54:03 PDT
*** Bug 8357 has been marked as a duplicate of this bug. ***
Comment 2 Mark Rowe (bdash) 2006-07-02 07:06:26 PDT
Confirmed with WebKit 418.8 and the latest WebKit nightly.  When repeatedly clicking hte "Random Article" link, no previous pages are added to the history.
Comment 3 Alexey Proskuryakov 2006-08-31 21:45:27 PDT
*** Bug 10658 has been marked as a duplicate of this bug. ***
Comment 4 Derk-Jan Hartman 2007-08-02 18:11:03 PDT
Here is what wikipedia returns. Perhaps it's due to the 302 ??

curl --user-agent "Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en) AppleWebKit/522.11.1 (KHTML, like Gecko) Version/3.0.3 Safari/522.12.1" -O "http://en.wikipedia.org/wiki/Special:Random" -v
* About to connect() to en.wikipedia.org port 80
*   Trying 145.97.39.155... * connected
* Connected to en.wikipedia.org (145.97.39.155) port 80
> GET /wiki/Special:Random HTTP/1.1
User-Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en) AppleWebKit/522.11.1 (KHTML, like Gecko) Version/3.0.3 Safari/522.12.1
Host: en.wikipedia.org
Pragma: no-cache
Accept: */*

< HTTP/1.0 302 Moved Temporarily
< Date: Fri, 03 Aug 2007 01:08:05 GMT
< Server: Apache
< X-Powered-By: PHP/5.1.4
< Vary: Accept-Encoding,Cookie
< Expires: Thu, 01 Jan 1970 00:00:00 GMT
< Cache-Control: private, s-maxage=0, max-age=0, must-revalidate
< Location: http://en.wikipedia.org/wiki/Linear_circuit
< Content-Length: 0
< Content-Type: text/html; charset=utf-8
< X-Cache: MISS from sq17.wikimedia.org
< X-Cache-Lookup: MISS from sq17.wikimedia.org:3128
< X-Cache: MISS from knsq5.knams.wikimedia.org
< X-Cache-Lookup: MISS from knsq5.knams.wikimedia.org:3128
< X-Cache: MISS from knsq4.knams.wikimedia.org
< X-Cache-Lookup: MISS from knsq4.knams.wikimedia.org:80
< Via: 1.0 sq17.wikimedia.org:3128 (squid/2.6.STABLE12), 1.0 knsq5.knams.wikimedia.org:3128 (squid/2.6.STABLE12), 1.0 knsq4.knams.wikimedia.org:80 (squid/2.6.STABLE12)
< Connection: close
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0* Closing connection #0

Comment 5 David Kilzer (:ddkilzer) 2007-09-08 09:31:26 PDT
Still occurs with a local debug build of WebKit r25410 with Safari 3 Public Beta v. 3.0.3 (522.12.1) on Mac OS X 10.4.10 (8R218).

Comment 6 Cameron Zwarich (cpst) 2008-06-10 23:07:24 PDT
This is a duplicate of bug 19422, and the patch there also fixes this problem. There is still the problem of rewriting the latest item in the history menu, but the back button works fine.

*** This bug has been marked as a duplicate of 19422 ***
Comment 7 Derk-Jan Hartman 2009-10-20 07:20:03 PDT
This issue is not fixed. I think only the first patch of the "duplicate" ticket fixed this problem, the patch that was eventually applied however does not seem to fix this issue.