Bug 78129 - [chromium] Support WebGL in multithreaded compositor
Summary: [chromium] Support WebGL in multithreaded compositor
Status: RESOLVED DUPLICATE of bug 80459
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebGL (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-08 10:19 PST by Kenneth Russell
Modified: 2012-03-06 18:00 PST (History)
8 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kenneth Russell 2012-02-08 10:19:22 PST
Currently Chromium's WebGL implementation doesn't work with the multithreaded compositor. In order to make it do so, minimally it will be necessary to add another color buffer so that the submission of WebGL rendering results to the compositor can be a true buffer swap. It might be worth adding two more buffers so that the rendering thread can submit results without ever blocking on the compositor and vice versa, though that would be overkill for the initial implementation.
Comment 1 Nat Duca 2012-02-15 14:52:15 PST
Iain has been thinking about how to reduce the backbuffer requirements for canvas layers recently. It would be pretty cool if we could have a 1 solution for both cases instead of 2. :)
Comment 2 James Robinson 2012-03-06 18:00:35 PST

*** This bug has been marked as a duplicate of bug 80459 ***