Bug 77892 - Give a name to attributes that might be invalid and needing updates
Summary: Give a name to attributes that might be invalid and needing updates
Status: NEW
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P4 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-06 12:06 PST by Caio Marcelo de Oliveira Filho
Modified: 2019-02-06 09:02 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Caio Marcelo de Oliveira Filho 2012-02-06 12:06:38 PST
While working on making NamedNodeMap a simple wrapper to Element, I noticed that some functions want to access attribute storage without updating invalid attributes (Style / SVG animations attributes can be marked as invalid). For example, we have hasAttributes() and hasAttributesWithoutUpdate(). The last one means no update of eventually invalid attributes will take place.

"WithoutUpdate" is too vague. Ryosuke Niwa proposed in IRC we could try to name those "special" attributes:

16:41 < cmarcelo> rniwa: hasAttributesWithoutUpdatingInvalidOnes()? I wouldn't want to mention the list explicitly, what if it 
                  changes.
16:42 < rniwa> cmarcelo: that's a good point
16:42 < rniwa> cmarcelo: maybe we need to give a name to the group of attributes that need to be dynamically updated
16:42 < rniwa> cmarcelo: maybe something like "RendererDependentAttribute"?
16:42 < rniwa> cmarcelo: or LayoutDependentAttributes?
16:42 < rniwa> cmarcelo: or DynamicAttribute?
16:43 < rniwa> cmarcelo: I like the last one least since every attribute is "dynamic" to some extent
16:43 < rniwa> cmarcelo: alas I don't like the fact seemingly generic word "update" is associated with a particular type of update 
               here.
16:44 < cmarcelo> rniwa: I understand. Having a clear name for them would help a lot.
16:44 < rniwa> cmarcelo: yeah but maybe it's fine to keep "WithoutUpdate" until we agree on some good name for it
Comment 1 Caio Marcelo de Oliveira Filho 2012-02-06 12:07:48 PST
Darin, do you have suggestions about this?
Comment 2 Lucas Forschler 2019-02-06 09:02:42 PST
Mass moving XML DOM bugs to the "DOM" Component.