Bug 77862 - Track text rendered multiple times
Summary: Track text rendered multiple times
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-06 02:35 PST by Sam Dutton
Modified: 2012-08-16 09:13 PDT (History)
5 users (show)

See Also:


Attachments
Screenshot of track element example with subtitles rendered three times (306.81 KB, image/png)
2012-02-06 02:35 PST, Sam Dutton
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sam Dutton 2012-02-06 02:35:17 PST
Created attachment 125602 [details]
Screenshot of track element example with subtitles rendered three times

What steps will reproduce the problem?

Open a page with a video with track element subtitles.


What is the expected result?

Subtitles rendered over video, once per track that has mode 2.


What happens instead?

Subtitles rendered multiple times. 

I've noticed this on several different sites, including the IE track examples. I've also seen a mode 1 metadata track rendered (on http://www.samdutton.com/track).
Comment 1 Eric Carlson 2012-02-07 08:50:36 PST
Strange, I am unable to reproduce this in Safari with current WebKit.
Comment 2 Anna Cavender 2012-08-14 16:12:19 PDT
Has anyone been able to repro this bug lately?  If no, I'm going to close as fixed.
Comment 3 Victor Carbune 2012-08-15 12:36:53 PDT
(In reply to comment #2)
> Has anyone been able to repro this bug lately?  If no, I'm going to close as fixed.
I haven't been able to reproduce it properly.
Comment 4 Arun Patole 2012-08-15 21:09:45 PDT
I was able to reproduce it on older chromium builds some months back but not with the latest one. So I think it must have been fixed by some recent changes and we should close this bug.
(In reply to comment #3)
> (In reply to comment #2)
> > Has anyone been able to repro this bug lately?  If no, I'm going to close as fixed.
> I haven't been able to reproduce it properly.
Comment 5 Sam Dutton 2012-08-16 03:01:56 PDT
I can't reproduce this now (in Chrome 21.0.1180.79 or 23.0.1235.0 canary)

Not here: http://www.samdutton.com/track/

...or here:  http://ie.microsoft.com/testdrive/Graphics/VideoCaptions/
Comment 6 Eric Carlson 2012-08-16 09:13:33 PDT
I suspect that this was fixed in one of Victor's rendering updates. 

Closing this bug, we can re-open if someone is able to reproduce the problem.