Bug 77791 - [GTK] Web content oftens steals focus from other widgets
: [GTK] Web content oftens steals focus from other widgets
Status: RESOLVED FIXED
: WebKit
WebKit Gtk
: 528+ (Nightly build)
: Unspecified Unspecified
: P2 Normal
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2012-02-03 16:15 PST by
Modified: 2012-02-20 18:04 PST (History)


Attachments
Patch (5.03 KB, patch)
2012-02-03 17:15 PST, Martin Robinson
no flags Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2012-02-03 16:15:43 PST
This is an annoying bug. To reproduce it, load Google in Epiphany and then quickly press "Ctr+L" to re-focus the address bar. The page will steal focus from the address bar shortly thereafter.
------- Comment #1 From 2012-02-03 16:18:16 PST -------
Believe it or not this seems to be a regression from 2007. Before that time a widget would only grab focus if it was backed by a real widget. Nowadays it grabs focus no matter what. If there is no real widget, it forces the WebView to grab focus.
------- Comment #2 From 2012-02-03 16:18:27 PST -------
Here's the change in question: http://trac.webkit.org/changeset/24963
------- Comment #3 From 2012-02-03 16:19:39 PST -------
Another interesting data point is that we were very diligent in making sure this bug also existed in WebKit2.
------- Comment #4 From 2012-02-03 17:15:19 PST -------
Created an attachment (id=125451) [details]
Patch
------- Comment #5 From 2012-02-20 18:04:14 PST -------
(From update of attachment 125451 [details])
Clearing flags on attachment: 125451

Committed r108278: <http://trac.webkit.org/changeset/108278>
------- Comment #6 From 2012-02-20 18:04:19 PST -------
All reviewed patches have been landed.  Closing bug.