Bug 7774 - REGRESSION: Moving selection below bottom of overflow area causes selection to jump to end
Summary: REGRESSION: Moving selection below bottom of overflow area causes selection t...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL:
Keywords: InRadar, Regression
: 10033 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-03-14 23:00 PST by Adele Peterson
Modified: 2007-02-20 13:08 PST (History)
4 users (show)

See Also:


Attachments
test case (2.42 KB, text/html)
2006-03-14 23:06 PST, Adele Peterson
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adele Peterson 2006-03-14 23:00:11 PST
See test case.

Since the selection jumps to the end of the content in the overflow area, the layer won't vertically autoscroll correctly.

This works fine in the horizontal direction.
Comment 1 Adele Peterson 2006-03-14 23:06:49 PST
Created attachment 7074 [details]
test case
Comment 2 Adele Peterson 2006-05-09 17:07:38 PDT
CC'ing Justin and Levi so they can take a look
Comment 3 David Kilzer (:ddkilzer) 2006-07-15 13:03:46 PDT
I only see this original bug on a true text area, not the content-editable div in the test case.  (It may be related to the behavior of Bug 9936.)

The content-editable div doesn't scroll at all when click-dragging outside of its boundaries, which makes it impossible to highlight beyond the visible area by click-dragging.

Comment 4 David Kilzer (:ddkilzer) 2006-07-15 13:38:25 PDT
(In reply to comment #3)
> I only see this original bug on a true text area, not the content-editable div
> in the test case.  (It may be related to the behavior of Bug 9936.)

Tested using a locally-built WebKit r15458 with Safari 2.0.4 (419.3) on Mac OS X 10.4.7 (8J135/PowerPC).

> The content-editable div doesn't scroll at all when click-dragging outside of
> its boundaries, which makes it impossible to highlight beyond the visible area
> by click-dragging.

I should note that I can make the c-e div scroll down (vertically) ONE line while click-dragging, but that's it.  It doesn't scroll horizontally at all.

Comment 5 David Kilzer (:ddkilzer) 2006-07-20 10:19:14 PDT
*** Bug 10033 has been marked as a duplicate of this bug. ***
Comment 6 Adele Peterson 2006-07-23 01:59:38 PDT
in the normal overflow div case, try adding in a few <br>s to break up the text node, and I think you'll see how its broken in that case too.
Comment 7 Stephanie Lewis 2006-11-06 18:27:35 PST
<rdar://problem/4822922> REGRESSION: Moving selection below bottom of overflow area causes selection to jump to end
Comment 8 Justin Garcia 2007-02-20 12:44:21 PST
Although the overflow area now autoscrolls correctly, the selection still jumps to the end.  So, the bug described in the title still exists.  Adele?
Comment 9 Adele Peterson 2007-02-20 13:08:53 PST
I don't see the selection jump.  When you drag past the bottom, it appears that the selection stops updating, which seems like a separate problem.