Bug 77601 - Rename [CheckFrameSecurity] and [SVGCheckSecurity] to [AllowAccessToNode]
Summary: Rename [CheckFrameSecurity] and [SVGCheckSecurity] to [AllowAccessToNode]
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore JavaScript (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Kentaro Hara
URL:
Keywords:
Depends on:
Blocks: 77393
  Show dependency treegraph
 
Reported: 2012-02-01 21:43 PST by Kentaro Hara
Modified: 2012-02-07 04:26 PST (History)
5 users (show)

See Also:


Attachments
Patch (11.61 KB, patch)
2012-02-01 21:54 PST, Kentaro Hara
no flags Details | Formatted Diff | Diff
patch for commit (11.60 KB, patch)
2012-02-01 22:18 PST, Kentaro Hara
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kentaro Hara 2012-02-01 21:43:16 PST
[CheckFrameSecurity] and [SVGCheckSecurity] have the same meaning; i.e. generate code to check allowAccessToNode() for a given attribute or method. We can rename them to [AllowAccessToNode].
Comment 1 Kentaro Hara 2012-02-01 21:54:00 PST
Created attachment 125076 [details]
Patch
Comment 2 Adam Barth 2012-02-01 22:02:37 PST
Comment on attachment 125076 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=125076&action=review

> Source/WebCore/ChangeLog:10
> +        to [AllowAccessToNode].

[AllowAccessToNode] isn't the best name.  It sounds like we're instructing the system to allow the access rather than to check for access.  Maybe [CheckAccessToNode] or [CheckAccessToResult] ?
Comment 3 Kentaro Hara 2012-02-01 22:18:57 PST
Created attachment 125080 [details]
patch for commit
Comment 4 Kentaro Hara 2012-02-01 22:19:50 PST
Comment on attachment 125076 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=125076&action=review

>> Source/WebCore/ChangeLog:10
>> +        to [AllowAccessToNode].
> 
> [AllowAccessToNode] isn't the best name.  It sounds like we're instructing the system to allow the access rather than to check for access.  Maybe [CheckAccessToNode] or [CheckAccessToResult] ?

Renamed to [CheckAccessToNode] and committed. Thanks!
Comment 5 WebKit Review Bot 2012-02-02 00:00:35 PST
Comment on attachment 125080 [details]
patch for commit

Clearing flags on attachment: 125080

Committed r106536: <http://trac.webkit.org/changeset/106536>