Bug 77257 - getParameter(COMPRESSED_TEXTURE_FORMATS) must return 0-length Uint32Array
Summary: getParameter(COMPRESSED_TEXTURE_FORMATS) must return 0-length Uint32Array
Status: RESOLVED DUPLICATE of bug 77066
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebGL (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
Depends on:
Reported: 2012-01-27 15:59 PST by Kenneth Russell
Modified: 2012-02-06 17:47 PST (History)
3 users (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Kenneth Russell 2012-01-27 15:59:14 PST
The spec for getParameter with the argument COMPRESSED_TEXTURE_FORMATS was recently changed to return a 0-length Uint32Array rather than null. WebKit's implementation needs to be changed to fix a conformance test failure.
Comment 1 Gregg Tavares 2012-02-06 17:44:14 PST
The patch for https://bugs.webkit.org/show_bug.cgi?id=77066 covers this.
Comment 2 Kenneth Russell 2012-02-06 17:47:11 PST
Fantastic, thanks. Closing this as a dup of the other.

*** This bug has been marked as a duplicate of bug 77066 ***