Bug 77209 - Web Inspector: [Styles] Unable to paste and subsequently edit multiple properties in the Styles pane
Summary: Web Inspector: [Styles] Unable to paste and subsequently edit multiple proper...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Alexander Pavlov (apavlov)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-27 05:43 PST by Alexander Pavlov (apavlov)
Modified: 2012-01-30 05:04 PST (History)
11 users (show)

See Also:


Attachments
Patch (4.81 KB, patch)
2012-01-27 08:13 PST, Alexander Pavlov (apavlov)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Pavlov (apavlov) 2012-01-27 05:43:24 PST
Weirdness ensues when a user tries to paste multiple properties into the Styles pane (editable property name field). We can parse one "key: value" pair at the moment.
Comment 1 Alexander Pavlov (apavlov) 2012-01-27 06:25:36 PST
The issue is with live-edit killing the style contents with multiplying properties from the "value" field.
Comment 2 Alexander Pavlov (apavlov) 2012-01-27 08:13:50 PST
Created attachment 124319 [details]
Patch
Comment 3 WebKit Review Bot 2012-01-30 05:04:43 PST
Comment on attachment 124319 [details]
Patch

Clearing flags on attachment: 124319

Committed r106237: <http://trac.webkit.org/changeset/106237>
Comment 4 WebKit Review Bot 2012-01-30 05:04:48 PST
All reviewed patches have been landed.  Closing bug.