Bug 76775 - [Qt] Split QtWebKit into two shared libraries
Summary: [Qt] Split QtWebKit into two shared libraries
Status: RESOLVED DUPLICATE of bug 99314
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Simon Hausmann
URL:
Keywords:
Depends on: 78109
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-20 23:31 PST by Simon Hausmann
Modified: 2012-11-29 05:17 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Hausmann 2012-01-20 23:31:27 PST
We need to be able to build WebKit in a way that we can produce a shared library
that contains the WK2 APIs and that itself does not depend on QtWidgets nor does it
link against any library that depends on QtWidgets.

That means at least WebCore and Source/WebKit2 need to be free of QtWidget
dependencies. And for Source/WebKit we need to figure out if we can build it
without QtWidgets by moving parts of it into a separate shared library.
Comment 1 Simon Hausmann 2012-02-16 05:01:38 PST
Let's change the description of this task slightly to reflect that the _goal_ is to have two libraries, a core one that contains the core of WebKit and the QML2 API, and a separate library that implements the WebKit1 Qt API that depends on QtWidgets.
Comment 2 Simon Hausmann 2012-11-29 05:17:47 PST

*** This bug has been marked as a duplicate of bug 99314 ***