Bug 76562 - Regression(r105233): fast/canvas/webgl/drawingbuffer-test.html fails
Summary: Regression(r105233): fast/canvas/webgl/drawingbuffer-test.html fails
Status: RESOLVED DUPLICATE of bug 76654
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebGL (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Jeff Timanus
URL:
Keywords:
Depends on: 76239
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-18 12:14 PST by Kenneth Russell
Modified: 2012-01-31 12:02 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kenneth Russell 2012-01-18 12:14:37 PST
The fix for https://bugs.webkit.org/show_bug.cgi?id=76239 appears to have regressed fast/canvas/webgl/drawingbuffer-test.html . See http://test-results.appspot.com/dashboards/flakiness_dashboard.html#tests=fast%2Fcanvas%2Fwebgl%2Fdrawingbuffer-test.html .
Comment 1 Kenneth Russell 2012-01-18 12:15:56 PST
Jeff, can you please take and/or shepherd through this bug?
Comment 2 Jeff Timanus 2012-01-18 12:28:30 PST
Having a look.
Comment 3 yongsheng 2012-01-18 18:05:35 PST
Copy from #76239:
Sorry, I should notify that the fix for this might expose the failure for these kind of cases which don't occur before. This kind of failure is somewhat random. Actually both 2 cases are almost the same.
The reason could be see from here: http://code.google.com/p/chromium/issues/detail?id=104740#c5
This case is also to test DrawingBuffer. And the root cause of this case is the same. The failure is because of the V8 GC issue. 

There are 2 ways:
1) revert the patch and commit it together with the patch for #76225(release GL context).
2) Or don't revert it and it will get fixed with the patch for #76225.
what's your opinion?
Comment 4 Kenneth Russell 2012-01-18 18:24:33 PST
See comment on Bug 76239.
Comment 5 Jeff Timanus 2012-01-31 12:02:55 PST
Fixed by issue 76654.

*** This bug has been marked as a duplicate of bug 76654 ***