Bug 75983 - Refactor RenderLayerBacking::paintIntoLayer and RenderLayer::paintLayer()/paintLayerContents() to avoid duplicate code
Summary: Refactor RenderLayerBacking::paintIntoLayer and RenderLayer::paintLayer()/pai...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Alexandru Chiculita
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-10 12:38 PST by Alexandru Chiculita
Modified: 2012-01-13 01:05 PST (History)
2 users (show)

See Also:


Attachments
Patch V1 (22.36 KB, patch)
2012-01-12 08:01 PST, Alexandru Chiculita
no flags Details | Formatted Diff | Diff
Patch for landing (23.26 KB, patch)
2012-01-13 00:38 PST, Alexandru Chiculita
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandru Chiculita 2012-01-10 12:38:39 PST
RenderLayerBacking::paintIntoLayer and RenderLayer::paintLayer()/paintLayerContents() have a lot of code in common. Find a way to refactor the methods to avoid duplicate code.
Comment 1 Alexandru Chiculita 2012-01-12 08:01:05 PST
Created attachment 122243 [details]
Patch V1
Comment 2 Alexandru Chiculita 2012-01-12 08:05:47 PST
Haven't sent for review yet. I want to see the EWS results first.
Comment 3 Alexandru Chiculita 2012-01-12 08:11:30 PST
Pasted the new code to http://pastebin.com/YsLaD1Ez to make it easier to see the actual source.
Comment 4 Simon Fraser (smfr) 2012-01-12 10:56:41 PST
Comment on attachment 122243 [details]
Patch V1

View in context: https://bugs.webkit.org/attachment.cgi?id=122243&action=review

> Source/WebCore/rendering/RenderLayer.cpp:2724
> +    // PaintLayerAppliedTransform is still being used for RenderReplica.

This comment is a bit confusing. It's not clear to me if it's a FIXME or what.

> Source/WebCore/rendering/RenderLayer.h:442
> +        PaintLayerPaintingBackgroundPhase = 1 << 5,
> +        PaintLayerPaintingForegroundPhase = 1 << 6,
> +        PaintLayerPaintingMaskPhase = 1 << 7,

I think it might help to have 'compositing' in these names. PaintLayerPaintingCompositingBackgroundPhase etc.
Comment 5 Alexandru Chiculita 2012-01-13 00:38:22 PST
Created attachment 122390 [details]
Patch for landing
Comment 6 WebKit Review Bot 2012-01-13 01:05:38 PST
Comment on attachment 122390 [details]
Patch for landing

Clearing flags on attachment: 122390

Committed r104903: <http://trac.webkit.org/changeset/104903>
Comment 7 WebKit Review Bot 2012-01-13 01:05:44 PST
All reviewed patches have been landed.  Closing bug.