Bug 75944 - Support the [Supplemental] IDL on methods
Summary: Support the [Supplemental] IDL on methods
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore JavaScript (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Kentaro Hara
URL:
Keywords:
Depends on:
Blocks: 72138
  Show dependency treegraph
 
Reported: 2012-01-10 01:03 PST by Kentaro Hara
Modified: 2012-01-10 15:49 PST (History)
6 users (show)

See Also:


Attachments
Patch (33.94 KB, patch)
2012-01-10 01:23 PST, Kentaro Hara
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kentaro Hara 2012-01-10 01:03:10 PST
Currently the [Supplemental] IDL is supported on attributes but not supported on methods. We should support it.

interface [Supplemental=XXXX]
YYYY {
    attribute int a;  // Supported
    void f();  // Not supported
}
Comment 1 Kentaro Hara 2012-01-10 01:23:57 PST
Created attachment 121811 [details]
Patch
Comment 2 WebKit Review Bot 2012-01-10 01:25:45 PST
Attachment 121811 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCor..." exit_code: 1

Source/WebCore/bindings/scripts/test/GObject/WebKitDOMTestInterface.cpp:80:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
Source/WebCore/bindings/scripts/test/GObject/WebKitDOMTestInterface.cpp:85:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Total errors found: 2 in 17 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 4 Kentaro Hara 2012-01-10 15:48:59 PST
Committed r104643: <http://trac.webkit.org/changeset/104643>
Comment 5 Kentaro Hara 2012-01-10 15:49:53 PST
Comment on attachment 121811 [details]
Patch

Committed manually to avoid style check error. Thanks.