But note bug 73147.
It would be trivial to fix this, and also seems it would do no harm if we later removed the concept of a detached range. So there is no reason not to add the 2-line check needed to comply.
(I also think we should change the bugs.webkit.org component name from XML DOM to Core DOM because the current name is too confusing.)
Created attachment 123144 [details]
View in context: https://bugs.webkit.org/attachment.cgi?id=123144&action=review
> + if ((m_start.container() && !refNode->attached())
This can be just !refNode->attached() now, no?
Created attachment 123154 [details]
(In reply to comment #3)
> View in context: https://bugs.webkit.org/attachment.cgi?id=123144&action=review
> > Source/WebCore/dom/Range.cpp:602
> > + if ((m_start.container() && !refNode->attached())
> This can be just !refNode->attached() now, no?
Yes, you are right. I did not notice that. new patch attached. Thanks.
Comment on attachment 123154 [details]
Clearing flags on attachment: 123154
Committed r105649: <http://trac.webkit.org/changeset/105649>
All reviewed patches have been landed. Closing bug.
Mass moving XML DOM bugs to the "DOM" Component.