Bug 7552 - Confluence WYSIWYG editor fails
Summary: Confluence WYSIWYG editor fails
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Evangelism (show other bugs)
Version: 417.x
Hardware: Macintosh OS X 10.4
: P2 Major
Assignee: Nobody
URL: http://confluence.atlassian.com/pages...
Keywords:
Depends on: 9915
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-02 08:38 PST by Colin Hardman
Modified: 2008-12-26 12:44 PST (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Colin Hardman 2006-03-02 08:38:05 PST
Load the above page on FireFox and Safari - safari fails to load the Rich Editor functionality. 

Also visible if go to demo of the editor they use
http://www.fckeditor.net/demo/default.html

I have to choose a single component - I don't know whether the problem is javascript or layout and rendering.

Also logged as an issue in confluence bug tracking - 
http://jira.atlassian.com/browse/CONF-3864
Comment 1 Gustaaf Groenendaal (MysteryQuest) 2006-03-04 15:37:13 PST
Well, this isn't a WebKit bug, but the builder of the site hides content while using a specified browser.
I saved the page with FireFox and opened it with WebKit and the site just works.
So to get this fixed is probably mailing the author of the site telling him that Safari/WebKit renders the page as it should be and it should be able to view the page Safari.

Example:

Safari case:

                <div class="minitab">
                <a id= "markupTab"  class="selectedminitab"  href="#" onClick="javascript:changeMode('markup');return false;">Wiki Markup</a>
                <a id= "previewTab"  class="unselectedminitab"  href="#" onClick="javascript:sendFormWithPreview();return false;">Preview</a>
                <img id="wysiwygWaitImage" style="visibility:hidden" alt="Wait Image" border=0 src="/images/icons/wait.gif">

FireFox case:

                <div class="minitab">
                <a id="wysiwygTab"  class="selectedminitab"  href="#" onClick="javascript:changeMode('richtext');return false;">Rich Text</a>

                <a id= "markupTab"  class="unselectedminitab"  href="#" onClick="javascript:changeMode('markup');return false;">Wiki Markup</a>
                <a id= "previewTab"  class="unselectedminitab"  href="#" onClick="javascript:changeMode('preview');return false;">Preview</a>
                <img id="wysiwygWaitImage" style="visibility:hidden" alt="Wait Image" border=0 src="/images/icons/wait.gif">

The only thing that bothers me on this is, is that i get the following message in Nightly webkit:
http://confluence.atlassian.com
Invalid reply from server
But this is an issue far away from the original.
Comment 2 David Kilzer (:ddkilzer) 2006-07-14 05:54:00 PDT
Retitled this bug since the goal is to support the FCKeditor.  Please add dependencies for other bugs to this one that prevent FCKeditor from running on Safari.

See also comments in Bug 4403, which notes that SiteMason (http://www.sitemason.com/) also uses FCKeditor.

Frederico, could you retest FCKeditor with a nightly build of WebKit (http://nightly.webkit.org/)?  There have been a lot of changes to support content editable divs in the last couple of months.  Also, it's hard to fix bugs when your demo site doesn't even attempt to let Safari/WebKit load the editor.

http://www.fckeditor.net/demo/default.html

Also confirming this bug since it crashes WebKit r15425 when it is set to spoof MSIE 6.

Comment 3 Frederico Caldeira Knabben 2006-07-14 06:57:50 PDT
The online demo is not intended to work with non supported browsers. A simple textarea is shown instead, and this is the expected behavior.

I've just created a Safari specific test page:
http://www.fckeditor.net/_temp/test_safari.html

It was already planned to create a "FCKeditor master bug" to FCKeditor and start including bugs dependencies on it. Should I do that with a new bug report? In this way we can remove all Confluence specific information, having a clearer report.

Thanks.
Comment 4 David Kilzer (:ddkilzer) 2006-07-14 07:10:44 PDT
(In reply to comment #3)
> The online demo is not intended to work with non supported browsers. A simple
> textarea is shown instead, and this is the expected behavior.
> 
> I've just created a Safari specific test page:
> http://www.fckeditor.net/_temp/test_safari.html

Thanks!

> It was already planned to create a "FCKeditor master bug" to FCKeditor and
> start including bugs dependencies on it. Should I do that with a new bug
> report? In this way we can remove all Confluence specific information, having a
> clearer report.

Sure, go ahead.  That would turn this (back) into an Evangelism bug.  Change the title of this bug back, change it to an Evangelism component, move its dependencies to the new bug, and add a dependency on this bug.  Thanks!

Comment 5 David Kilzer (:ddkilzer) 2006-07-14 08:08:01 PDT
(In reply to comment #4)
> Sure, go ahead.  That would turn this (back) into an Evangelism bug.  Change
> the title of this bug back, change it to an Evangelism component, move its
> dependencies to the new bug, and add a dependency on this bug.  Thanks!

If you don't have permissions to do any of this, let me know.

Comment 6 Frederico Caldeira Knabben 2006-07-14 08:08:41 PDT
Ok... I've created Bug 9915. I'm not able to make changes on this one. Can you update it? Thanks.
Comment 7 David Kilzer (:ddkilzer) 2006-07-14 08:17:53 PDT
Changing this back to an evangelism bug for Confluence.

It depends on Bug 9915 being fixed first before Atlassian can enable Safari with Confluence.

Comment 8 David Weintraub 2008-03-07 13:33:27 PST
I've looked into this issue before about five months ago. Confluence actually tests the browser. If it detects that your browser is Safari, it prevents you from using the WYSIWYG editor.
Comment 9 Robert Blaut 2008-12-26 12:41:21 PST
I test Confluence rich text editor on this page http://confluence.demo.atlassian.com/pages/createpage.action?spaceKey=TEST&fromPageId=557061 using the latest WebKit and I found no problem here. 

So apparently this bug is fixed. David, could you confirm it?
Comment 10 Robert Blaut 2008-12-26 12:44:48 PST
 Confluence 2.10 introduced Safari support: http://confluence.atlassian.com/display/DOC/Confluence+2.10+Release+Notes :) So definitely it is fixed :)