Bug 7542 - REGRESSION: (r13028) Scrolling causes incomplete drawing of <ul> bullets
Summary: REGRESSION: (r13028) Scrolling causes incomplete drawing of <ul> bullets
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Justin Garcia
URL: http://en.wikipedia.org/w/index.php?t...
Keywords: Regression
Depends on:
Blocks:
 
Reported: 2006-03-01 14:24 PST by Steven Fisher
Modified: 2006-03-02 13:40 PST (History)
1 user (show)

See Also:


Attachments
System profile (944.48 KB, text/plain)
2006-03-01 14:34 PST, Steven Fisher
no flags Details
Screenshot (355.80 KB, image/png)
2006-03-01 14:34 PST, Steven Fisher
no flags Details
Broken bullets; some are "thinner" (39.37 KB, image/png)
2006-03-01 22:18 PST, crastinator
no flags Details
patch (506 bytes, patch)
2006-03-02 12:21 PST, Justin Garcia
sullivan: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Steven Fisher 2006-03-01 14:24:28 PST
Nightshift build 2006-02-28; recreated on new user account. Unable to recreate in Safari 2.0.3.

Scrolling causes incomplete drawing of <ul> bullets.

1. Visit URL above: http://en.wikipedia.org/w/index.php?title=Quicksilver_%28software%29&oldid=40652040
2. Using the mouse wheel, scroll down to the long bullet lists in "Interfaces with other applications." Some of the bullets will be missing or partially drawn.
Comment 1 Steven Fisher 2006-03-01 14:32:59 PST
Also reproduced using scroll bars instead of scroll wheel.
Comment 2 Steven Fisher 2006-03-01 14:34:10 PST
Created attachment 6795 [details]
System profile
Comment 3 Steven Fisher 2006-03-01 14:34:55 PST
Created attachment 6796 [details]
Screenshot
Comment 4 crastinator 2006-03-01 22:16:29 PST
Got the same thing here, they also become vertically "thinner" sometimes. It comes up when using directional keys, doesn't come up when using page up/down.
Using build r13060, 10.4.5
Comment 5 crastinator 2006-03-01 22:18:10 PST
Created attachment 6803 [details]
Broken bullets; some are "thinner"
Comment 6 mitz 2006-03-01 22:57:19 PST
Looks like "the regression version" of bug 4855.
Comment 7 Steven Fisher 2006-03-02 09:45:41 PST
#6: Well, I can't recreate this one (7542) on the shipping Safari. Doesn't that make this a regression, or have I erred?
Comment 8 mitz 2006-03-02 10:23:42 PST
(In reply to comment #7)
> #6: Well, I can't recreate this one (7542) on the shipping Safari. Doesn't that
> make this a regression, or have I erred?
> 

Sorry, my previous comment was poorly-phrased and incorrect.

This bug is a regression, and based on testing with nightly builds, it is probably a regression from the fix for bug 6844.
Comment 9 Steven Fisher 2006-03-02 11:19:14 PST
Thanks for the explanation. Sorry if I seemed offended or something, I wasn't. I was just trying not to ramble. :)
Comment 10 Justin Garcia 2006-03-02 12:12:32 PST
Here it is:
+    IntRect box(_tx + m_x, _ty + m_y, m_height, m_width);
Oops!
Comment 11 Justin Garcia 2006-03-02 12:21:05 PST
Created attachment 6810 [details]
patch

I also looked through  the rest of my checkin to make sure I didn't make the same mistake more than once.  
I'm not sure how I would create an automated test for this.
Comment 12 John Sullivan 2006-03-02 13:00:15 PST
Comment on attachment 6810 [details]
patch

Seems OK to me to check in without a layout test, but maybe someone else will have an idea about how to create one.
Comment 13 Justin Garcia 2006-03-02 13:40:14 PST
landing with a layout test that mitz wrote