Bug 75303 - REGRESSION (r98196-98236): Incorrect layout of iGoogle with RSS feeds
Summary: REGRESSION (r98196-98236): Incorrect layout of iGoogle with RSS feeds
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Mac (Intel) OS X 10.7
: P1 Normal
Assignee: Nobody
URL: http://www.google.nl/ig#t_0
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2011-12-28 03:46 PST by Frank Eetgerink
Modified: 2012-01-03 16:07 PST (History)
5 users (show)

See Also:


Attachments
the patch (154.02 KB, patch)
2012-01-03 15:46 PST, Filip Pizlo
barraclough: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Eetgerink 2011-12-28 03:46:09 PST
The iGoogle page loads the attached gadgets/rss feeds but does not build the page correctly.
It stops resizing the page after the first length definition and then squeezes in all the remaining gadgets.
Comment 1 Alexey Proskuryakov 2011-12-28 21:13:53 PST
Are you seeing this in Safari, Chrome, or only in WebKit nightlies from <http://nightly.webkit.org>?
Comment 2 Frank Eetgerink 2011-12-29 02:33:19 PST
Safari and Chrome work just fine. They first draw the correct page size and then fill in the feeds.
Comment 3 Alexey Proskuryakov 2011-12-31 11:43:43 PST
To reproduce, I started with a new iGoogle page, and added a CNN technology news RSS feed.

There is a new error in console compared to shipping WebKit:


Class$S194: Exception caught: Exception caught: Exception caught: Exception caught: Exception caught: Exception caught: (TypeError) 
 line: 1
 sourceId: 140607346329584
 sourceURL: http://www.google.nl/ig#t_0: 'undefined' is not an object (evaluating 'this.x.id')
Comment 4 Alexey Proskuryakov 2011-12-31 11:45:17 PST
<rdar://problem/10633533>
Comment 5 Alexey Proskuryakov 2012-01-02 23:40:11 PST
This issue doesn't seem to be happening after r103887. I'm not sure whether that fixed the root cause or not.
Comment 6 Filip Pizlo 2012-01-03 15:46:18 PST
Created attachment 121008 [details]
the patch
Comment 7 Filip Pizlo 2012-01-03 16:07:33 PST
Landed in http://trac.webkit.org/changeset/103981