Bug 75135 - Assertion failure in Document::setCompatibilityMode
Summary: Assertion failure in Document::setCompatibilityMode
Status: RESOLVED DUPLICATE of bug 68859
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 75131
  Show dependency treegraph
 
Reported: 2011-12-22 15:13 PST by Simon Fraser (smfr)
Modified: 2012-02-24 10:23 PST (History)
3 users (show)

See Also:


Attachments
Crash log for assertion (44.45 KB, text/plain)
2011-12-22 15:13 PST, Simon Fraser (smfr)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2011-12-22 15:13:07 PST
Created attachment 120390 [details]
Crash log for assertion

One of these crashing tests:

 11$ $ ./Tools/Scripts/run-webkit-tests -2 --debug LayoutTests/fast/
  fast/block/float/014.html -> unexpected DumpRenderTree crash
  fast/block/margin-collapse/006.html -> unexpected text diff mismatch
  fast/backgrounds/background-position-1.html -> unexpected text diff mismatch
  fast/block/margin-collapse/block-inside-inline/021.html -> unexpected text diff mismatch
  fast/block/positioning/014.html -> unexpected text diff mismatch
  fast/block/float/intruding-float-remove-from-sibling-block-on-fixed-position.html -> unexpected text diff mismatch
  fast/body-propagation/overflow/005-declarative.xhtml -> unexpected text diff mismatch
  fast/block/margin-collapse/010.html -> unexpected DumpRenderTree crash
  fast/backgrounds/background-position-parsing.html -> unexpected DumpRenderTree crash
  fast/block/margin-collapse/block-inside-inline/022.html -> unexpected DumpRenderTree crash
  fast/block/positioning/015.html -> unexpected DumpRenderTree crash
  fast/canvas/webgl/webgl-viewport-parameters-preserved.html -> unexpected text diff mismatch
  fast/block/float/intruding-painted-twice.html -> unexpected DumpRenderTree crash
  fast/body-propagation/overflow/005-xhtml.xhtml -> unexpected DumpRenderTree crash
  fast/css/counters/complex-before.html -> unexpected text diff mismatch
  fast/css/bidi-override-in-anonymous-block.html -> unexpected text diff mismatch
  fast/dom/constructed-objects-prototypes.html -> unexpected text diff mismatch
  fast/dom/frame-loading-via-document-write.html -> unexpected text diff mismatch
  fast/clip/001.html -> unexpected text diff mismatch    
  fast/dom/horizontal-scrollbar-in-rtl.html -> unexpected text diff mismatch
  fast/css-generated-content/014.html -> unexpected text diff mismatch
  fast/body-propagation/overflow/006-declarative.xhtml -> unexpected text diff mismatch
  fast/block/positioning/absolute-in-inline-rtl-2.html -> unexpected text diff mismatch
  fast/css/counters/counter-increment-001.html -> unexpected text diff mismatch
  fast/clip/002.html -> unexpected DumpRenderTree crash  
  fast/css-generated-content/015.html -> unexpected DumpRenderTree crash
  fast/body-propagation/overflow/006-xhtml.xhtml -> unexpected DumpRenderTree crash
  fast/block/positioning/absolute-in-inline-rtl-3.html -> unexpected DumpRenderTree crash
  fast/css/counters/counter-increment-002.html -> unexpected DumpRenderTree crash
  fast/animation/request-animation-frame-iframe.html -> unexpected test timed out
Testing (36%): 2745 ran as expectedstopping WebKitTestRunner timed out, killing it
killed
  fast/dom/Window/window-properties.html -> unexpected text diff mismatch
  fast/dynamic/crash-paint-no-documentElement-renderer.html -> unexpected DumpRenderTree crash
  fast/dom/Window/window-property-descriptors.html -> unexpected text diff mismatch
  fast/css-generated-content/block-after.html -> unexpected text diff mismatch
  fast/dom/prototype-inheritance-2.html -> unexpected text diff mismatch
  fast/block/positioning/padding-percent.html -> unexpected text diff mismatch
  fast/events/blur-focus-window-should-blur-focus-element.html -> unexpected text diff mismatch
  fast/dom/HTMLElement/attr-dir-auto-change-text-form-control.html -> unexpected text diff mismatch
  fast/css/pseudo-cache-stale.html -> unexpected DumpRenderTree crash
  fast/css-generated-content/drag-state.html -> unexpected DumpRenderTree crash
  fast/dom/prototype-inheritance.html -> unexpected DumpRenderTree crash
  fast/block/positioning/positioned-float-layout-after-image-load.html -> unexpected DumpRenderTree crash
  fast/dom/HTMLProgressElement/progress-clone.html -> unexpected text diff mismatch
  fast/dom/HTMLElement/attr-dir-auto-change-text.html -> unexpected DumpRenderTree crash
  fast/dom/HTMLProgressElement/progress-element-form.html -> unexpected DumpRenderTree crash
Exiting early after 19 crashes and 1 timeouts. 3521 tests run.

is asserting in Document::setCompatibilityMode()
Comment 1 Alexey Proskuryakov 2012-01-12 17:05:02 PST
fast/dom/getter-on-window-object2.html fails this assertion on Lion running WK1 tests.
Comment 2 Alexey Proskuryakov 2012-01-12 17:06:51 PST
Hmm, maybe the new test runner pointed to a wrong crash log. But one test or another, I saw this assertion on Lion with WK1.
Comment 3 Julien Chaffraix 2012-02-24 10:23:20 PST
Weird that you hit this ASSERT during your testing. The only test I knew failing with this ASSERT was fast/dynamic/crash-paint-no-documentElement-renderer.html and it is now disabled.

*** This bug has been marked as a duplicate of bug 68859 ***