Bug 7505 - textarea width doesn't correctly correspond to cols attribute
Summary: textarea width doesn't correctly correspond to cols attribute
Status: RESOLVED DUPLICATE of bug 15312
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 420+
Hardware: Mac OS X 10.4
: P4 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-27 20:09 PST by Justin Garcia
Modified: 2009-04-28 16:14 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Garcia 2006-02-27 20:09:27 PST
Open the following snippit it the Snippit Editor:

<textarea style="font-family:Courier New" cols="5">123456789</textarea>

The textarea is wide enough to accomodate 1234567 on the first line.  With a fixed width font like Courier New, the first line should only accomodate 12345.  

See:
http://www.w3.org/TR/html401/interact/forms.html
Comment 1 Ojan Vafai 2009-04-28 16:14:37 PDT

*** This bug has been marked as a duplicate of 15312 ***