Bug 74928 - enable USE_SKIA_TEXT by default, replacing GDI for all text drawing
Summary: enable USE_SKIA_TEXT by default, replacing GDI for all text drawing
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Mike Reed
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-20 07:09 PST by Mike Reed
Modified: 2012-04-05 13:28 PDT (History)
4 users (show)

See Also:


Attachments
Patch (1.06 KB, patch)
2011-12-20 07:12 PST, Mike Reed
no flags Details | Formatted Diff | Diff
Manually confirmed rebaselines (281.90 KB, patch)
2012-04-05 12:44 PDT, Philip Rogers
no flags Details | Formatted Diff | Diff
Manually confirmed rebaselines (v2: fix bug in previous patch) (273.52 KB, patch)
2012-04-05 13:00 PDT, Philip Rogers
no flags Details | Formatted Diff | Diff
Manually confirmed rebaselines (v3: fix bug in previous patch) (264.85 KB, patch)
2012-04-05 13:05 PDT, Philip Rogers
no flags Details | Formatted Diff | Diff
Manually confirmed rebaselines (v4: fix bug in previous patch) (257.65 KB, patch)
2012-04-05 13:14 PDT, Philip Rogers
no flags Details | Formatted Diff | Diff
Manually confirmed rebaselines (v5: fix bug in previous patch. One day I'll get this right.) (250.07 KB, patch)
2012-04-05 13:19 PDT, Philip Rogers
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Reed 2011-12-20 07:09:40 PST
enable USE_SKIA_TEXT by default, replacing GDI for all text drawing
Comment 1 Mike Reed 2011-12-20 07:12:17 PST
Created attachment 120025 [details]
Patch
Comment 2 Mike Reed 2011-12-20 07:14:37 PST
local DRT run is clean.
images differences already noted in text_expectations.txt (see BUGCR99500) to be rebaselined after this lands.
Comment 3 Stephen White 2011-12-20 07:56:07 PST
Comment on attachment 120025 [details]
Patch

OK.  Looks like the chromium-ews bot is stuck.  Please keep an eye on the canary bots after landing.  r=me
Comment 4 WebKit Review Bot 2011-12-20 14:05:46 PST
Comment on attachment 120025 [details]
Patch

Clearing flags on attachment: 120025

Committed r103349: <http://trac.webkit.org/changeset/103349>
Comment 5 WebKit Review Bot 2011-12-20 14:05:50 PST
All reviewed patches have been landed.  Closing bug.
Comment 6 Philip Rogers 2012-04-05 12:44:16 PDT
Created attachment 135879 [details]
Manually confirmed rebaselines
Comment 7 Philip Rogers 2012-04-05 13:00:23 PDT
Created attachment 135882 [details]
Manually confirmed rebaselines (v2: fix bug in previous patch)
Comment 8 Philip Rogers 2012-04-05 13:05:52 PDT
Created attachment 135883 [details]
Manually confirmed rebaselines (v3: fix bug in previous patch)
Comment 9 Philip Rogers 2012-04-05 13:14:14 PDT
Created attachment 135887 [details]
Manually confirmed rebaselines (v4: fix bug in previous patch)
Comment 10 Philip Rogers 2012-04-05 13:19:42 PDT
Created attachment 135889 [details]
Manually confirmed rebaselines (v5: fix bug in previous patch. One day I'll get this right.)
Comment 11 Stephen Chenney 2012-04-05 13:28:16 PDT
Comment on attachment 135889 [details]
Manually confirmed rebaselines (v5: fix bug in previous patch. One day I'll get this right.)

Clearing flags on attachment: 135889

Committed r113368: <http://trac.webkit.org/changeset/113368>
Comment 12 Stephen Chenney 2012-04-05 13:28:23 PDT
All reviewed patches have been landed.  Closing bug.