Bug 74891 - Blur filter doesn't invalidate enough
Summary: Blur filter doesn't invalidate enough
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Simon Fraser (smfr)
URL:
Keywords: InRadar
: 71929 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-12-19 15:05 PST by Simon Fraser (smfr)
Modified: 2011-12-23 09:02 PST (History)
2 users (show)

See Also:


Attachments
Testcase (606 bytes, text/html)
2011-12-19 15:05 PST, Simon Fraser (smfr)
no flags Details
Patch (19.95 KB, patch)
2011-12-22 16:36 PST, Simon Fraser (smfr)
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2011-12-19 15:05:06 PST
Created attachment 119922 [details]
Testcase

Blur doesn't take the blur radius into account when invalidating, resulting in repaint issues.
Comment 1 Simon Fraser (smfr) 2011-12-22 16:36:07 PST
Created attachment 120408 [details]
Patch
Comment 2 Radar WebKit Bug Importer 2011-12-22 16:36:19 PST
<rdar://problem/10622089>
Comment 3 Simon Fraser (smfr) 2011-12-22 16:56:45 PST
*** Bug 71929 has been marked as a duplicate of this bug. ***
Comment 4 Darin Adler 2011-12-23 08:03:56 PST
Comment on attachment 120408 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=120408&action=review

> Source/WebCore/rendering/RenderBox.cpp:1581
> +        LayoutUnit topOutset;
> +        LayoutUnit rightOutset;
> +        LayoutUnit bottomOutset;
> +        LayoutUnit leftOutset;
> +        style()->filter().getOutsets(topOutset, rightOutset, bottomOutset, leftOutset);

Reads like an argument for an outsets struct.
Comment 5 Simon Fraser (smfr) 2011-12-23 09:02:29 PST
http://trac.webkit.org/changeset/103631