Bug 74655 - Regression (r102866): Navigating away from or closing a page with a plugin crashes
Summary: Regression (r102866): Navigating away from or closing a page with a plugin cr...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Anders Carlsson
URL:
Keywords: InRadar
: 74684 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-12-15 15:36 PST by Brady Eidson
Modified: 2011-12-16 15:35 PST (History)
3 users (show)

See Also:


Attachments
Patch (3.99 KB, patch)
2011-12-15 17:55 PST, Anders Carlsson
sam: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Brady Eidson 2011-12-15 15:36:55 PST
Regression (r102866): Navigating away from a cachable page with a plugin crashes

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   com.apple.WebKit2             	0x000000010f7d694f CoreIPC::Connection::dispatchConnectionDidClose() + 63 (Connection.cpp:606)
1   com.apple.WebKit2             	0x000000010f7ddc10 WTF::FunctionWrapper<void (CoreIPC::Connection::*)()>::operator()(CoreIPC::Connection*) + 112 (Functional.h:135)
2   com.apple.WebKit2             	0x000000010f7ddb95 WTF::BoundFunctionImpl<WTF::FunctionWrapper<void (CoreIPC::Connection::*)()>, void ()(CoreIPC::Connection*)>::operator()() + 37 (Functional.h:221)
3   com.apple.WebKit2             	0x000000010f83e978 WTF::Function<void ()()>::operator()() + 136 (Functional.h:299)
4   com.apple.WebKit2             	0x000000010f83e8dc FunctionWorkItem::execute() + 28 (WorkItem.h:230)
5   com.apple.WebKit2             	0x000000010f83d82f RunLoop::performWork() + 207 (RunLoop.cpp:64)
6   com.apple.WebKit2             	0x000000010f83ebb0 RunLoop::performWork(void*) + 96 (RunLoopMac.mm:38)

The crashing line is:
    client->didClose(this);
Comment 1 Brady Eidson 2011-12-15 15:38:54 PST
<rdar://problem/10590024>
Comment 2 Brady Eidson 2011-12-15 16:56:40 PST
You can actually trigger this just by closing a tab with a page with a plug-in - I noticed closing a tab with Yelp.
Comment 3 Anders Carlsson 2011-12-15 17:55:11 PST
Created attachment 119530 [details]
Patch
Comment 4 WebKit Review Bot 2011-12-15 17:58:20 PST
Attachment 119530 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/ChangeLog', u'Source..." exit_code: 1

Tools/TestWebKitAPI/Tests/WTF/Functional.cpp:156:  Code inside a namespace should not be indented.  [whitespace/indent] [4]
Tools/TestWebKitAPI/Tests/WTF/Functional.cpp:166:  More than one command on the same line  [whitespace/newline] [4]
Tools/TestWebKitAPI/Tests/WTF/Functional.cpp:169:  More than one command on the same line  [whitespace/newline] [4]
Total errors found: 3 in 4 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 5 Anders Carlsson 2011-12-15 18:00:53 PST
Committed r103008: <http://trac.webkit.org/changeset/103008>
Comment 6 Alexey Proskuryakov 2011-12-16 15:35:08 PST
*** Bug 74684 has been marked as a duplicate of this bug. ***