Bug 74433 - Inaccurate IDL for NotificationCenter.requestPermission
Summary: Inaccurate IDL for NotificationCenter.requestPermission
Status: RESOLVED DUPLICATE of bug 63615
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Minor
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-13 11:51 PST by Stephen Adams
Modified: 2011-12-15 15:00 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stephen Adams 2011-12-13 11:51:11 PST
Example code like http://www.html5rocks.com/en/tutorials/notifications/quick/ calls requestPermission with no arguments.

The webkit IDL declares requestPermission with one parameter:

       [Custom] void requestPermission(in VoidCallback callback);

If the parameter is optional, please mark it as optional in the IDL.

Also, does this operation really need to be custom?
Comment 1 Jon Lee 2011-12-15 15:00:45 PST
Merging this request into bug 63615, which implements the optional parameter.

*** This bug has been marked as a duplicate of bug 63615 ***