Bug 74413 - [Qt] REGRESSION(102679): It broke Qt5-WK1 build
Summary: [Qt] REGRESSION(102679): It broke Qt5-WK1 build
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P1 Blocker
Assignee: Nobody
URL:
Keywords: Qt, QtTriaged
Depends on:
Blocks:
 
Reported: 2011-12-13 08:37 PST by Csaba Osztrogonác
Modified: 2012-02-02 10:13 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Csaba Osztrogonác 2011-12-13 08:37:20 PST
It broke Qt5-WK1 build (building with --no-webkit2 option):

/mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/Api/qwebkitversion.cpp:21:28: error: qwebkitversion.h: No such file or directory
In file included from /mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/WebCoreSupport/QtFallbackWebPopup.cpp:22:
/mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/WebCoreSupport/QtFallbackWebPopup.h:24:35: error: qwebkitplatformplugin.h: No such file or directory
/mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/Api/qwebkitversion.cpp:41: error: ‘QString’ does not name a type
make[3]: *** [obj/release/WebKit/qt/Api/qwebkitversion.o] Error 1
make[3]: *** Waiting for unfinished jobs....
In file included from /mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/Api/qgraphicswebview.cpp:31:
/mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/WebCoreSupport/PageClientQt.h:29:30: error: qgraphicswebview.h: No such file or directory
/mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/WebCoreSupport/PageClientQt.h:30:23: error: qwebframe.h: No such file or directory
/mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/WebCoreSupport/PageClientQt.h:31:25: error: qwebframe_p.h: No such file or directory
/mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/WebCoreSupport/PageClientQt.h:32:22: error: qwebpage.h: No such file or directory
/mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/WebCoreSupport/QtFallbackWebPopup.cpp:29:30: error: qgraphicswebview.h: No such file or directory
/mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/WebCoreSupport/PageClientQt.h:33:24: error: qwebpage_p.h: No such file or directory
In file included from /mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/WebCoreSupport/EditorClientQt.h:35,
                 from /mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/Api/qwebpage.cpp:56:
/mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/WebCoreSupport/TextCheckerClientQt.h:34:35: error: qwebkitplatformplugin.h: No such file or directory
In file included from /mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/Api/qwebpage.cpp:70:
/mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/WebCoreSupport/GeolocationPermissionClientQt.h:35:22: error: qwebpage.h: No such file or directory
In file included from /mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/Api/qwebpage.cpp:91:
/mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/WebCoreSupport/PageClientQt.h:29:30: error: qgraphicswebview.h: No such file or directory
/mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/WebCoreSupport/PageClientQt.h:30:23: error: qwebframe.h: No such file or directory
/mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/WebCoreSupport/PageClientQt.h:31:25: error: qwebframe_p.h: No such file or directory
/mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/WebCoreSupport/PageClientQt.h:33:24: error: qwebpage_p.h: No such file or directory
In file included from /mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/WebCoreSupport/QtFallbackWebPopup.cpp:22:
/mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/WebCoreSupport/QtFallbackWebPopup.h:41: error: expected class-name before ‘{’ token
/mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/WebCoreSupport/QtFallbackWebPopup.h:47: error: ISO C++ forbids declaration of ‘QWebSelectData’ with no type
/mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/WebCoreSupport/QtFallbackWebPopup.h:47: error: expected ‘,’ or ‘...’ before ‘&’ token
/mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/WebCoreSupport/QtFallbackWebPopup.h:68: error: ISO C++ forbids declaration of ‘QWebSelectData’ with no type
/mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/WebCoreSupport/QtFallbackWebPopup.h:68: error: expected ‘,’ or ‘...’ before ‘&’ token
/mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/WebCoreSupport/QtFallbackWebPopup.cpp:46: error: prototype for ‘void WebCore::QtFallbackWebPopup::show(const QWebSelectData&)’ does not match any in class ‘WebCore::QtFallbackWebPopup’
/mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/WebCoreSupport/QtFallbackWebPopup.h:47: error: candidate is: virtual void WebCore::QtFallbackWebPopup::show(int)
/mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/WebCoreSupport/QtFallbackWebPopup.cpp:81: error: prototype for ‘void WebCore::QtFallbackWebPopup::populate(const QWebSelectData&)’ does not match any in class ‘WebCore::QtFallbackWebPopup’
/mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/WebCoreSupport/QtFallbackWebPopup.h:68: error: candidate is: void WebCore::QtFallbackWebPopup::populate(int)
/mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/WebCoreSupport/QtFallbackWebPopup.cpp: In member function ‘void WebCore::QtFallbackWebPopup::activeChanged(int)’:
/mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/WebCoreSupport/QtFallbackWebPopup.cpp:121: error: ‘selectItem’ was not declared in this scope
make[3]: *** [obj/release/WebKit/qt/WebCoreSupport/QtFallbackWebPopup.o] Error 1
In file included from /mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/Api/qwebpage.cpp:91:
/mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/WebCoreSupport/PageClientQt.h:158: error: expected ‘)’ before ‘*’ token
/mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/WebCoreSupport/PageClientQt.h:220: error: ISO C++ forbids declaration of ‘QGraphicsWebView’ with no type
/mnt/ssd/qt-linux-32-release-qt5/build/Source/WebKit/qt/WebCoreSupport/PageClientQt.h:220: error: expected ‘;’ before ‘*’ token
Comment 1 Csaba Osztrogonác 2011-12-13 09:22:51 PST
I landed a workaround/buildfix for it: http://trac.webkit.org/changeset/102684
Could you guys check it and find a better fix?

Additionally I fixed the debug build fail caused by r102679:
http://trac.webkit.org/changeset/102681
Could you check it too?
Comment 2 Csaba Osztrogonác 2011-12-13 09:27:36 PST
Ooops, I missed to add you to the cc list. :)
Comment 3 Tor Arne Vestbø 2011-12-13 11:05:54 PST
Thanks, I'll fix it tomorrow. api.pro should INCLUDEPATH += Source/WebKit/qt/API
Comment 4 Csaba Osztrogonác 2012-02-02 10:13:04 PST
It was fixed long time ago.