Bug 74401 - [Chromium] Pull in FreeType and decrease check-out complexity for Android
Summary: [Chromium] Pull in FreeType and decrease check-out complexity for Android
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Peter Beverloo
URL:
Keywords:
Depends on:
Blocks: 66689
  Show dependency treegraph
 
Reported: 2011-12-13 04:49 PST by Peter Beverloo
Modified: 2011-12-13 13:23 PST (History)
3 users (show)

See Also:


Attachments
Patch (4.43 KB, patch)
2011-12-13 04:50 PST, Peter Beverloo
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Beverloo 2011-12-13 04:49:10 PST
Source/WebKit/chromium/

    Pull in FreeType in the third_party/ directory from a separate git repository at Chromium. This introduces a new prerequisite for checking out the Chromium WebKit port for Android, namely that git needs to be available on the system. gclient can handle this just fine.

    Since only one git-dependency is required in the case of the Android version, I chose not to create an "chromium_git" variable (similar to "chromium_svn") in order to keep it isolated.

Tools/

    Decrease the check-out complexity by removing the need to first run "update-webkit-chromium --chromium" prior to running it with "--chromium-android", which was caused by an unversioned third_party/ directory being created. This moves the Android NDK to Source/WebKit/ chromium/, coming from third_party/ in that directory.
Comment 1 Peter Beverloo 2011-12-13 04:50:08 PST
Created attachment 119007 [details]
Patch
Comment 2 WebKit Review Bot 2011-12-13 13:23:19 PST
Comment on attachment 119007 [details]
Patch

Clearing flags on attachment: 119007

Committed r102700: <http://trac.webkit.org/changeset/102700>
Comment 3 WebKit Review Bot 2011-12-13 13:23:27 PST
All reviewed patches have been landed.  Closing bug.