Bug 74220 - V8Proxy cleanup: replace custom logging methods with standard WebCore calls
Summary: V8Proxy cleanup: replace custom logging methods with standard WebCore calls
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Adam Klein
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-09 14:44 PST by Adam Klein
Modified: 2012-03-06 12:32 PST (History)
5 users (show)

See Also:


Attachments
Patch (5.49 KB, patch)
2011-12-09 14:45 PST, Adam Klein
no flags Details | Formatted Diff | Diff
Update test expectations (6.69 KB, patch)
2011-12-09 15:10 PST, Adam Klein
no flags Details | Formatted Diff | Diff
Patch for landing (5.43 KB, patch)
2011-12-12 17:50 PST, Adam Klein
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Klein 2011-12-09 14:44:53 PST
V8Proxy cleanup: replace custom logging methods with standard WebCore calls
Comment 1 Adam Klein 2011-12-09 14:45:16 PST
Created attachment 118645 [details]
Patch
Comment 2 Adam Klein 2011-12-09 15:10:40 PST
Created attachment 118653 [details]
Update test expectations
Comment 3 Adam Barth 2011-12-12 16:43:28 PST
Comment on attachment 118653 [details]
Update test expectations

View in context: https://bugs.webkit.org/attachment.cgi?id=118653&action=review

> LayoutTests/fast/xpath/nsresolver-bad-object-expected.txt:1
> -CONSOLE MESSAGE: line 0: XPathNSResolver does not have a lookupNamespaceURI method.
> +CONSOLE MESSAGE: line 1: XPathNSResolver does not have a lookupNamespaceURI method.

Is this going to cause a problem for JSC ports?
Comment 4 Adam Klein 2011-12-12 16:55:15 PST
(In reply to comment #3)
> (From update of attachment 118653 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=118653&action=review
> 
> > LayoutTests/fast/xpath/nsresolver-bad-object-expected.txt:1
> > -CONSOLE MESSAGE: line 0: XPathNSResolver does not have a lookupNamespaceURI method.
> > +CONSOLE MESSAGE: line 1: XPathNSResolver does not have a lookupNamespaceURI method.
> 
> Is this going to cause a problem for JSC ports?

Arg....probably? Guess I'll have to fix this code to pass 0 in.
Comment 5 Adam Klein 2011-12-12 17:50:30 PST
Created attachment 118925 [details]
Patch for landing
Comment 6 WebKit Review Bot 2011-12-12 19:33:26 PST
Comment on attachment 118925 [details]
Patch for landing

Rejecting attachment 118925 [details] from commit-queue.

New failing tests:
http/tests/inspector/resource-tree/resource-tree-document-url.html
Full output: http://queues.webkit.org/results/10847197
Comment 7 Adam Klein 2011-12-13 08:56:04 PST
Comment on attachment 118925 [details]
Patch for landing

Test failure looked like a flake, trying again.
Comment 8 WebKit Review Bot 2011-12-13 10:20:38 PST
Comment on attachment 118925 [details]
Patch for landing

Clearing flags on attachment: 118925

Committed r102688: <http://trac.webkit.org/changeset/102688>
Comment 9 WebKit Review Bot 2011-12-13 10:20:43 PST
All reviewed patches have been landed.  Closing bug.
Comment 10 Kenneth Russell 2011-12-14 10:03:49 PST
Reverted r102688 for reason:

Under the hypothesis that it might be the cause of browser_tests and ui_tests crashes on Chromium canaries -- will reland if not.

Committed r102794: <http://trac.webkit.org/changeset/102794>
Comment 11 Kenneth Russell 2011-12-14 19:22:13 PST
Reverted r102794 for reason:

Reapplying patch since it is not the cause of the problems described in bug 74220.

Committed r102871: <http://trac.webkit.org/changeset/102871>