Bug 73760 - Assertion failure in CachedResource::addClientToSet while browsing on engadet.com
: Assertion failure in CachedResource::addClientToSet while browsing on engadet...
Status: RESOLVED DUPLICATE of bug 78834
: WebKit
Page Loading
: 528+ (Nightly build)
: Unspecified Unspecified
: P2 Normal
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2011-12-03 20:36 PST by
Modified: 2012-02-17 14:09 PST (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-12-03 20:36:07 PST
Stack trace:

ASSERTION FAILED: !isPurgeable()
/Users/rniwa/webkit/Source/WebCore/loader/cache/CachedResource.cpp(380) : void WebCore::CachedResource::addClientToSet(WebCore::CachedResourceClient*)
1   0x101f29bbf WebCore::CachedResource::addClientToSet(WebCore::CachedResourceClient*)
2   0x101f2a097 WebCore::CachedResource::addClient(WebCore::CachedResourceClient*)
3   0x102cf6b25 WebCore::StyleCachedImage::addClient(WebCore::RenderObject*)
4   0x102b46c0e WebCore::RenderObject::updateFillImages(WebCore::FillLayer const*, WebCore::FillLayer const*)
5   0x102b4d762 WebCore::RenderObject::setStyle(WTF::PassRefPtr<WebCore::RenderStyle>)
6   0x102b4b426 WebCore::RenderObject::setAnimatableStyle(WTF::PassRefPtr<WebCore::RenderStyle>)
7   0x1029ce8fa WebCore::NodeRendererFactory::createRenderer()
8   0x1029cf45a WebCore::NodeRendererFactory::createRendererIfNeeded()
9   0x1029bd90e WebCore::Node::createRendererIfNeeded()
10  0x102264c3b WebCore::Element::attach()
11  0x101f8718c WebCore::ContainerNode::attach()
12  0x102264c6d WebCore::Element::attach()
13  0x101f8718c WebCore::ContainerNode::attach()
14  0x102264c6d WebCore::Element::attach()
15  0x101f4b091 WebCore::Node::reattach()
16  0x102264450 WebCore::Element::recalcStyle(WebCore::Node::StyleChange)
17  0x102264a39 WebCore::Element::recalcStyle(WebCore::Node::StyleChange)
18  0x102264a39 WebCore::Element::recalcStyle(WebCore::Node::StyleChange)
19  0x10211e2ea WebCore::Document::recalcStyle(WebCore::Node::StyleChange)
20  0x10211f5f8 WebCore::Document::updateStyleIfNeeded()
21  0x10210e5a4 WebCore::Document::updateStyleForAllDocuments()
22  0x102c51c17 WebCore::ScheduledAction::execute(WebCore::Document*)
23  0x102c51cca WebCore::ScheduledAction::execute(WebCore::ScriptExecutionContext*)
24  0x1022185a4 WebCore::DOMTimer::fired()
25  0x102e1c464 WebCore::ThreadTimers::sharedTimerFiredInternal()
26  0x102e1c677 WebCore::ThreadTimers::sharedTimerFired()
27  0x102cb1fb2 WebCore::timerFired(__CFRunLoopTimer*, void*)
28  0x7fff81a01bb8 __CFRunLoopRun
------- Comment #1 From 2011-12-04 21:01:10 PST -------
It's not immediately clear if this is a CSS issue or a page loading one.
------- Comment #2 From 2011-12-05 09:01:07 PST -------
What is special about the resource that is causing the assertion?
------- Comment #3 From 2011-12-05 12:37:37 PST -------
I'm hitting this assertion intermittently on Mac when browsing "back" to a page that loads images using the background-image CSS attribute. I think this may be related to or causing the following issue that has been reported to Chromium: http://code.google.com/p/chromium/issues/detail?id=70268
------- Comment #4 From 2012-02-16 15:16:12 PST -------
japhet has posted a patch for this issue on Chromium Bug http://code.google.com/p/chromium/issues/detail?id=111218

http://code.google.com/p/chromium/issues/attachmentText?id=111218&aid=1112180029000&name=purge.txt&token=_DaxbOW_9S9EBpe9nqfGokF3TOA%3A1329433694325

After this patch, addClientToSet forces the resource to be unpurgeable if it's currently purgeable.

This will probably also fix webkit bug 78834 and thereby fix Chromium bug http://code.google.com/p/chromium/issues/detail?id=111027
------- Comment #5 From 2012-02-16 16:33:35 PST -------
(In reply to comment #4)
> japhet has posted a patch for this issue on Chromium Bug http://code.google.com/p/chromium/issues/detail?id=111218
> 
> http://code.google.com/p/chromium/issues/attachmentText?id=111218&aid=1112180029000&name=purge.txt&token=_DaxbOW_9S9EBpe9nqfGokF3TOA%3A1329433694325
> 
> After this patch, addClientToSet forces the resource to be unpurgeable if it's currently purgeable.
> 
> This will probably also fix webkit bug 78834 and thereby fix Chromium bug http://code.google.com/p/chromium/issues/detail?id=111027

The patch doesn't appear to fix the problem in bug 78834. Let me know what I can do to help track this one down.
------- Comment #6 From 2012-02-17 14:09:03 PST -------

*** This bug has been marked as a duplicate of bug 78834 ***