Bug 73752 - Assertion hit in HistoryItem::addChildItem while navigating on facebook
: Assertion hit in HistoryItem::addChildItem while navigating on facebook
Status: RESOLVED DUPLICATE of bug 51224
: WebKit
History
: 528+ (Nightly build)
: Unspecified Unspecified
: P2 Normal
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2011-12-03 12:18 PST by
Modified: 2011-12-05 13:29 PST (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-12-03 12:18:31 PST
Stack trace:

ASSERTION FAILED: !childItemWithTarget(child->target())
/Users/rniwa/webkit/Source/WebCore/history/HistoryItem.cpp(463) : void WebCore::HistoryItem::addChildItem(WTF::PassRefPtr<WebCore::HistoryItem>)
1   0x10237b9ff WebCore::HistoryItem::addChildItem(WTF::PassRefPtr<WebCore::HistoryItem>)
2   0x10237967f WebCore::HistoryController::createItemTree(WebCore::Frame*, bool)
3   0x1023797b3 WebCore::HistoryController::pushState(WTF::PassRefPtr<WebCore::SerializedScriptValue>, WTF::String const&, WTF::String const&)
4   0x1023775de WebCore::History::stateObjectAdded(WTF::PassRefPtr<WebCore::SerializedScriptValue>, WTF::String const&, WTF::String const&, WebCore::History::StateObjectType, int&)
5   0x102675540 WebCore::JSHistory::pushState(JSC::ExecState*)
6   0x10267403b WebCore::jsHistoryPrototypeFunctionPushState(JSC::ExecState*)
7   0x326bb7601218
8   0x1000f1aac JSC::JITCode::execute(JSC::RegisterFile*, JSC::ExecState*, JSC::JSGlobalData*)
9   0x1000e80fe JSC::Interpreter::executeCall(JSC::ExecState*, JSC::JSObject*, JSC::CallType, JSC::CallData const&, JSC::JSValue, JSC::ArgList const&)
10  0x100062257 JSC::call(JSC::ExecState*, JSC::JSValue, JSC::CallType, JSC::CallData const&, JSC::JSValue, JSC::ArgList const&)
11  0x102578ec2 WebCore::JSMainThreadExecState::call(JSC::ExecState*, JSC::JSValue, JSC::CallType, JSC::CallData const&, JSC::JSValue, JSC::ArgList const&)
12  0x102653767 WebCore::JSEventListener::handleEvent(WebCore::ScriptExecutionContext*, WebCore::Event*)
13  0x10228ae84 WebCore::EventTarget::fireEventListeners(WebCore::Event*, WebCore::EventTargetData*, WTF::Vector<WebCore::RegisteredEventListener, 1ul>&)
14  0x10228b3ca WebCore::EventTarget::fireEventListeners(WebCore::Event*)
15  0x1029b8b45 WebCore::Node::handleLocalEvents(WebCore::Event*)
16  0x10226e145 WebCore::EventDispatcher::dispatchEvent(WTF::PassRefPtr<WebCore::Event>)
17  0x1029a4b3f WebCore::MouseEventDispatchMediator::dispatchEvent(WebCore::EventDispatcher*) const
18  0x10226d4cb WebCore::EventDispatcher::dispatchEvent(WebCore::Node*, WTF::PassRefPtr<WebCore::EventDispatchMediator>)
19  0x1029b875b WebCore::Node::dispatchMouseEvent(WebCore::PlatformMouseEvent const&, WTF::AtomicString const&, int, WebCore::Node*)
20  0x1022777c7 WebCore::EventHandler::dispatchMouseEvent(WTF::AtomicString const&, WebCore::Node*, bool, int, WebCore::PlatformMouseEvent const&, bool)
21  0x10227898b WebCore::EventHandler::handleMouseReleaseEvent(WebCore::PlatformMouseEvent const&)
22  0x10227fdff WebCore::EventHandler::mouseUp(NSEvent*)
23  0x100be4764 -[WebHTMLView mouseUp:]
24  0x7fff82538431 -[NSWindow sendEvent:]
25  0x7fff89ce121a -[Window sendEvent:]
26  0x7fff89ade0ab -[BrowserWindow sendEvent:]
27  0x7fff8246dafa -[NSApplication sendEvent:]
28  0x7fff89a843cd -[BrowserApplication sendEvent:]
29  0x7fff824046de -[NSApplication run]
30  0x7fff823fd3b0 NSApplicationMain
31  0x7fff89c3fb3c SafariMain
------- Comment #1 From 2011-12-05 13:29:20 PST -------

*** This bug has been marked as a duplicate of bug 51224 ***