Bug 73730 - <video> elements should disable the system and display sleep when playing on OS X.
: <video> elements should disable the system and display sleep when playing on ...
Status: RESOLVED FIXED
: WebKit
New Bugs
: 528+ (Nightly build)
: Unspecified Unspecified
: P2 Normal
Assigned To:
:
: InRadar
:
:
  Show dependency treegraph
 
Reported: 2011-12-02 18:48 PST by
Modified: 2011-12-19 10:34 PST (History)


Attachments
Patch (2.63 KB, patch)
2011-12-02 21:58 PST, Jer Noble
no flags Review Patch | Details | Formatted Diff | Diff
Patch (2.50 KB, patch)
2011-12-02 22:24 PST, Jer Noble
no flags Review Patch | Details | Formatted Diff | Diff
Patch (2.71 KB, patch)
2011-12-02 23:32 PST, Jer Noble
no flags Review Patch | Details | Formatted Diff | Diff
Patch (4.21 KB, patch)
2011-12-03 15:56 PST, Jer Noble
ap: review+
Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-12-02 18:48:33 PST
<video> elements should disable the system and display sleep when playing on OS X.
------- Comment #1 From 2011-12-02 21:58:51 PST -------
Created an attachment (id=117740) [details]
Patch
------- Comment #2 From 2011-12-02 22:24:21 PST -------
Created an attachment (id=117743) [details]
Patch
------- Comment #3 From 2011-12-02 23:32:13 PST -------
Created an attachment (id=117746) [details]
Patch
------- Comment #4 From 2011-12-02 23:39:42 PST -------
(From update of attachment 117746 [details])
View in context: https://bugs.webkit.org/attachment.cgi?id=117746&action=review

> Source/WebCore/html/HTMLMediaElement.cpp:2508
> +        m_sleepDisabler = DisplaySleepDisabler::create("WebCore::HTMLMediaElement playback");

The reason for the power assertion doesn’t match the format used elsewhere in WebKit. It would be good to be consistent.
------- Comment #5 From 2011-12-02 23:46:22 PST -------
Also, it would be great if you could mention the associated Radar number both in Bugzilla and the ChangeLog.
------- Comment #6 From 2011-12-03 15:53:57 PST -------
<rdar://problem/9502155>
------- Comment #7 From 2011-12-03 15:56:45 PST -------
Created an attachment (id=117773) [details]
Patch

While Mark already r+'d the previous patch, I thought this new patch was worth obsoleting that one.  This new patch has changes to the WebKit2 sandbox profile, which allows DisplaySleepDisabler to work when running in the WebProcess.
------- Comment #8 From 2011-12-05 10:59:26 PST -------
(From update of attachment 117773 [details])
r=me
------- Comment #9 From 2011-12-05 11:47:29 PST -------
Committed r102024: <http://trac.webkit.org/changeset/102024>
------- Comment #10 From 2011-12-19 10:34:02 PST -------
*** Bug 65061 has been marked as a duplicate of this bug. ***