The difference between inlineStyleDecl() and getInlineStyleDecl() is way too subtle. I suggest we rename getInlineStyleDecl() to ensureInlineStyleDecl().
Call sites should also store the return value in a CSSInlineStyleDeclaration*.
Furthermore, we should make StyledElement::style() explicitly virtual and decorate it with OVERRIDE.
Created attachment 117443 [details]
Comment on attachment 117443 [details]
Clearing flags on attachment: 117443
Committed r101707: <http://trac.webkit.org/changeset/101707>
All reviewed patches have been landed. Closing bug.